Ford Power Stroke Nation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
got a '03, died at a stop light.Got towed home and to make a long story short I found that the hpop failed. I could see aluminum shaving coming out around the shaft seal of the hpop. I shook the pump and everything was loose inside. Checked my oil filter and found a LOT of shavings between the groves. Drained my oil into a clean container and found no shavings... yeah, weird i know. then i took a L-shaped piece of tie wire and tried to hook some shavings out of the base pan drain. Never found any shavings there either.... What should i do now? buy a used hpop for $200 and see how long the engine lasts? How much shavings are in my injectors now? or is that engine even worth a $200 pump?
 

·
"resident smarty pants"
Joined
·
4,327 Posts
I would be concerned about the metal being in the injectors.

how many miles on it?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Got a used hpop for a good deal. Slapped it in the bitch and everything seems fine.... Im going to leave it idling in the driveway for a few hours and change the filter a couple times. i think if the shaving were going to ruin the injectors i would have known by now.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Changed oil and filter 5 through the course of a few weeks. Still found large amounts of aluminum shavings on the oil filter! But too expensive to do anymore oil changes.... anyway the truck was working fine up until yesterday. Injector #2 is dead. now to make up enough funds for a new engine... i need to go vomit now
 

·
Hood Rich
Joined
·
2,873 Posts
always recommend to flush the oil rails out and clean spool valves... the injector is probably still useable, its just jammed with a piece of the pie....
 
1 - 8 of 8 Posts
Top