Ford Power Stroke Nation banner

1 - 7 of 7 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
When towing a 12,000lbs fith wheel my obs likes to run hot when climing long grades when the amp temp is over 75deg. 230-235 is when I'm getting out of it, my egts never get over 1250. I dont no if the Hyper max taper core is blocking to much air or if the stage 3 injectors are to big. The trans temp runs 15 deg below the trucks temp. I've had the radator cleaned and rodded. Has any body found a extra heavy duty radator. I've found by placing a close ball valve in heater hose it slows the rate of temp clime. Also Water wetter has slowed the rate but not fixed it.
 

·
Registered
Joined
·
3,369 Posts
Are you running the stock fan? As a suggestion you might want to fill out a truck signature with what you have on your truck for mods in that way we can possibly better assist with suggestions...

jrc
 

·
Registered
Joined
·
37 Posts
Discussion Starter #4
Yes my fan is stock , and beleave the clutch is good, unless I don't understand how to check. I understand that your clutch should be easy to turn with some drag when cold, but when the truck is warmed it gets much harder to turn. <Maybe> Mont
 

·
Registered
Joined
·
50 Posts
There's a way to stick a piece of cardboard in front of the clutch and rev the engine. It should heat it up and apply the full fan. If you can't hear the fan when it's that hot (it's LOUD!!) you likely have a bad fan clutch.

BTDT. They seem to be working properly, but if they are not locking up that are broken.
 
1 - 7 of 7 Posts
Top