Ford Power Stroke Nation banner

1 - 13 of 13 Posts

·
Thirsty For More
Joined
·
280 Posts
Discussion Starter #1
Two days ago my driving lights, cab lights, backlight for dash and the heater and a/c knobs, and fog lights all stopped working. This morning I went out to start my truck and the batteries were so dead it wouldnt even crank. Got it charged and got the alternater tested and its still good. Probably going to get new batteries with 850 or more CCAs.
So here's where I am, started checking fuses and cant seem to find one that is burned out. Wondering it if could be a relay but none of them control all that electrical stuff through a single relay. If anyone has any ideas they would be greatly appreciated. Thanks
 

·
Registered
Joined
·
8 Posts
years ago my on my stepdad's f250 they found that the dealer installed lights on the roof of the cab had not been sealed, they live in AZ where it "never rains", and during rainstorms while travelling water was seeping in and running down the inside of the A pillar and draining into tbe backside of the fuse box. Corroded everything until it was fully resistave. Had to replace fuse box and then everything was A-OK. Oh, and seal those pesky roof lights.
 

·
Thirsty For More
Joined
·
280 Posts
Discussion Starter #4
I guess im just guna double check the fuses and fuse box and then find a volt meter and work my way from the lights back
 

·
Registered
Joined
·
646 Posts
years ago my on my stepdad's f250 they found that the dealer installed lights on the roof of the cab had not been sealed, they live in AZ where it "never rains", and during rainstorms while travelling water was seeping in and running down the inside of the A pillar and draining into tbe backside of the fuse box. Corroded everything until it was fully resistave. Had to replace fuse box and then everything was A-OK. Oh, and seal those pesky roof lights.
That's crazy!!! What are the odds hey?
 

·
Registered
Joined
·
175 Posts
Subscribed. Got a buddy who has the exact same issue. We were going down the road the other night with a 34ft. gooseneck with 2 play jeeps and all the lights went out, even the trailers. Pulled over, turned it off let it set for 5 mins and it worked fine. I suspect a ground somewhere.
 

·
Thirsty For More
Joined
·
280 Posts
Discussion Starter #7
Well if he figures his out please let me know, I probably wont get around to going through everything till next weekend
 

·
Administrator
Joined
·
32,970 Posts
looking at the manual there is a 30 amp fuse f2.7that feeds the main light switch and that would seem to explain your outages I would pull and test and like mentioned verify grounds are good
however the dead batts and no start IDK
 

·
Administrator
Joined
·
32,970 Posts
it didn't give me the location and this is for an 06 but it is in the main fuse box in the cab there shouldn't be a bunch of 30's what year is yours you never mentioned and the link didn't work
 

·
Thirsty For More
Joined
·
280 Posts
Discussion Starter #12
its an 03. the link was from the manual you posted in another thread i had up about this. Hopefully tomorrow after work i can start going through everything, im guna start at the fuses and then check grounds on the switch itself
 
1 - 13 of 13 Posts
Top