Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
2003 6.0, 6-speed, 38,000 miles Truck makes no power or boost until I reach about 2500 RPM. I thought it was a sticking turbo, so I bought a new Powermax. I installed that and it changed nothing. Fuel pressure is good 55 psi at WOT. FICM is good at 47-48 volts. I checked ICP and IPR with scangauge

Start up ICP-840 IPR-38
Coolant 100 degrees Low Idle ICP-557 IPR-26.0
Coolant 100 degrees High Idle 1200rpm ICP-639 IPR 27.8
Driving up grade WOT at 3000rpm ICP-2500
After WOT parked at low idle ICP-440 IPR-21.1

I am suspecting it is the HPOP, but I already threw $1200 at it with the Powermax. Was thinking about replacing ICP,IPR ,HPOP and while I'm in there an oil cooler. Not sure if it could be anything else. Truck starts good and runs smooth, just no boost or power at all until high rpm. Any help would be greatly appreciated.
 

·
Registered
Joined
·
113 Posts
Injectors can do the same thing, sometime they don't feel like a miss but they'll make your truck feel like its slow until you're in the higher rpm's then it'll start to go. Have a injector contribution test done. They really show their colors on cold start and while in gear at idle
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Can I perform an injector contribution test with my scangauge.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Just checked at 2500rpm ICP is 1037 and IPR is38.7
 

·
Registered
Joined
·
113 Posts
I'm not sure about your scan gauge. I use the Ids, there are a few others I know snap on and Marco make one that will do it.
 
1 - 5 of 5 Posts
Top