Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
ok since ive installed my new turbo chip pumps fuel pump intercooler 203 t and electric fans i had it start running real choppy in the driveway and die ended up being the passenger side injector harness
now after installing my bts and 6.0 cooler i drove it fine for 2 days and idling in my friends driveway for 2 minutes it dies suddenly cranks but no smoke and it wont start this time the idm is fried
could this be the chip? i have dp-tuner from jody anyone know what it could be does the idm just where out i only have 72,000 miles but it is a 2000 any ideas? :shrug:
 

·
Registered
Joined
·
6,652 Posts
need to scan codes. Usually with a fried IDM it will come up open bank 1 and 2 high. Indicating no communication with the IDM.

I have an extra you could try, but a little far away.

Definitely pull the chip and see if that helps too.

Oh, and WELCOME. Thank you for joining. Go introduce yourself all formal now :D
 

·
Premium Member
Joined
·
2,982 Posts
ok since ive installed my new turbo chip pumps fuel pump intercooler 203 t and electric fans i had it start running real choppy in the driveway and die ended up being the passenger side injector harness
now after installing my bts and 6.0 cooler i drove it fine for 2 days and idling in my friends driveway for 2 minutes it dies suddenly cranks but no smoke and it wont start this time the idm is fried
could this be the chip? i have dp-tuner from jody anyone know what it could be does the idm just where out i only have 72,000 miles but it is a 2000 any ideas? :shrug:

Need a little more infomation.

There has only been one other time that I can recall that the chip actually took out an IDM. It's not a common thing. The chip was pulled out while the truck was running and and it fried the PCM and IDM both.

A few questions-
I am sure it was taped in, but had the chip come loose do you think? Did you double check to make sure the wires under the valve cover had not come loose? How did you determine it was the IDM that is dead? It could be the PCM. Make sure what it is because IDM's are a pretty penny if you have buy one from a dealership if you can't find a good one at a salvage yard. Same goes for a PCM.

let us know what you find out.

Diane
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
i couldnt figure it out so i sent it to ford... both times, the wiring harness i assumed may have been from the oil leak from the hpop when it went but it worked for a few weeks... and the idm i dont know why it would i taped the chip in prety damn good and drilled the computer plastic surrounding to make the wire to the controller have no force on it i just got it back an hour ago $1197 :fordoval::badidea:
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
module alone 768.78
 
1 - 5 of 5 Posts
Top