Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter #1
Best way to explain it, is it runs like gas engine when a spark plug is fouled, or like it has a bad plug wire.

When it first started acting up, the engine missed until it warmed up, so i replaced the glow plugs, and GPR. No difference.

But it ran smooth once up to operating temp, then as it got worse, it would only run smooth while under a load and increasing EGT's.

Now, it doesn't change at all, at any rpm, it just has a miss, did I have an injector go bad?

I haven't had an income for a few months and have let the truck sit for the last month until i could work on it, where do i start?
Thanks
 

·
Registered
Joined
·
3,940 Posts
Have it scanned so you don't waste time and money.
 

·
Catfish Mafia
Joined
·
397 Posts
i had a very similar issue with mine after my turbo swap. #7 kept failing the contribution tests. i thought it was and injector issue.. was bad or not sealed. had DI pull the injector and check. they just cleaned it out and put it back in.. problem soved. what i'm getting at is it may be something simple.. dirty injector. find someone with a scanner and run a contribution test. that should narrow it down. also do an injector buzz test. mine passed the buzz but failed the contribution. maybe this helps.
 

·
Registered
Joined
·
141 Posts
Discussion Starter #4
Thanks for the info, now I just need to find where to take it, I have less than zero confidence in the local dealer.

Frankly, they have been wrong EVERY time I or any of my friends have an issue. they are batting ZERO! But thanks to my friends here @ Power Stroke Nation, the 1st WAG suggestions have been probably 75% accurate, maybe more based on my symptoms.

How do you do a Cyl contribution test, and injector buzz test? sounds like I need to take it to a professional diesel shop. So who is close to Minnesota? I'm thinking Black widow was in Iowa.
 

·
All done now
Joined
·
22,486 Posts
Check out this list. I bet there is someone close to you that can help you out.

Powerstroke Nation

You can click on any of the column headers and sort it by that column.
 

·
Registered
Joined
·
141 Posts
Discussion Starter #6
Thanks Guys,

When i started digging into this, found the UVC harness loose. Plugged it back in and put some zipties on in to hold it in place.

Runs great!
 
1 - 6 of 6 Posts
Top