Ford Power Stroke Nation banner

1 - 20 of 26 Posts

·
BLCKOUT
Joined
·
1,672 Posts
Discussion Starter #1
Ok so already had problems before with a burned out bulb and after who knows how long I finally got a new set.

Now both headlights are taking turns not workins, last night it was the left, tonight it is the right. Sometimes they both work just fine.

I think the problem lies in the GOS harness, bc I have the GOS harness to convert to the newer style, then the HID harness as well. I had problems with the GOS harness before.

Question is is there a way to take the GOS harness completely out and and cut the connectors off my factory harnes and hardwire it to the HID harness?
I have been dealing with this for a while now and it is getting reallly really old. Funny that my $50 ebay HID fogs are working better than the "name brand" headlights
 

·
Sofa King Cool
Joined
·
2,827 Posts
You can either cut off both plugs and hardwire them to your factory harness, or build your own relay harness to draw clean power from the batts.

Myself I cut the plugs, used two relays and made my own harness
 

·
PSN Mega Miler
Joined
·
6,480 Posts
Yep you can cut them. Easier just to call retro and have them mail you the right harness adapters. They are cheap and will work great.
 

·
Registered
Joined
·
1,885 Posts
I have been having problems with my adapter harness, I forgot where I ordered it from. Multiple times, I have had to bang on the lights to get them to turn on, or to get them to "brighten" up. I am getting rid of the adapter harness, and all the BS and just go HID's. Maybe by winter.
 

·
Registered
Joined
·
1,711 Posts
Ok so already had problems before with a burned out bulb and after who knows how long I finally got a new set.

Now both headlights are taking turns not workins, last night it was the left, tonight it is the right. Sometimes they both work just fine.

I think the problem lies in the GOS harness, bc I have the GOS harness to convert to the newer style, then the HID harness as well. I had problems with the GOS harness before.

Question is is there a way to take the GOS harness completely out and and cut the connectors off my factory harnes and hardwire it to the HID harness?
I have been dealing with this for a while now and it is getting reallly really old. Funny that my $50 ebay HID fogs are working better than the "name brand" headlights
that hid kit sucks i had nothing but problems with mine
 

·
PSN Mega Miler
Joined
·
6,480 Posts
The retro solutions kit sucks? LOL
Not.

Installed mine waaaaaay back and it hasnt given a single problem at all.

Will be ordering 2 more kits in the last part of november or early december.
 

·
BLCKOUT
Joined
·
1,672 Posts
Discussion Starter #10
Well I spoke to freakin soon, got in the truck tonight and left headlight was out!! WTF!!!!!!!!!!! Then it majically came on ridin down the road. I am pullin the whole kit out tomorrow and sending it back for a full phucking refund and buying another $50 ebay special for the headlights
 

·
PSN Mega Miler
Joined
·
6,480 Posts
Best solution is simply finding whats knocking it out. On hid kits, retros or anybodies its normally a ground problem.

A bad kit, aka somethings wrong with it, its not going to come back on for two reasons. If you notice when you first turn the lights on they are very dim and then get up to full brightness after a few seconds. This is the ballast firing up. A bad ballast or other bad parts will fire the ballast off when first turned on and wont fire again because it thinks the lights are still on.

A wiring problem with your truck on the other hand will be the same as you turing the lights off and back on. Thus it will fire the ballast off like its suposed to causing the light to come back on while driving.

I dont care personally if you switch to another kit. But even if you want to do that Id find the problem with the kit you have now, cause it isnt going to be fixed by switching kits.

The kit you have now being a retro kit has a lifetime warranty and great tech suport if you contact them.


Also since myself and several others are running that kit we probably can help you find the problem if you want to tackle it still.
 

·
PSN Mega Miler
Joined
·
6,480 Posts
yeah man i but a set in march iv had nothing but problems with them

The kit you posted the link to when I searched your post was for a different kit than the retro solutions kit.
 

·
PSN Mega Miler
Joined
·
6,480 Posts

·
PSN Veteran
Joined
·
2,983 Posts
Retro-Soultions here, LOVE the kit. Id look into fixing what you have now, like crowz said, just switching doesnt always fix the issue
 

·
Registered
Joined
·
878 Posts
I have to agree with crowz some'n is wrong with yo truck wiring boss.....I have had nothing but perfection out of mine.....55w bi kit......:ford:
 

·
I FINALLY JUMPED!
Joined
·
516 Posts
I had a problem with my kit with no relay burning out my SJB on my 08 but you guys probably dont have those. I agree just giving up on them and changin wont always fix the problem.
 

·
Registered
Joined
·
1,092 Posts
I had this issue with one of my Retro HID kits. It ended up being a bad relay (the relay that was included with the adjustable output kit).

Email Retrosolutions. They did a great job helping me trouble-shoot my issue.
 
1 - 20 of 26 Posts
Top