Ford Power Stroke Nation banner

1 - 8 of 8 Posts

·
Big Sun fanatic
Joined
·
111 Posts
Discussion Starter #1
Hi all, I've read a little bit about this but can't find where I read it at. I recently installed some 160cc injectors and a chip, and I've noticed that when I push in the clutch to shift the rpm's seem to hang (or even increase a bit) before dropping. It's ok if I'm givin er because I can shift without losing significant rpms but it's a pita if I'm just driving normally around town. I've only got about an hour on the truck after install, not sure whether it just takes time to work itself out? Any suggestions would be helpful.
 

·
Registered
Joined
·
2,411 Posts
This usually happens when the IPR can't dump HPO fast enough or the IPR map isn't adjusted optimally and ICP is hangs high when the the accelerator pedal is released.
 

·
Big Sun fanatic
Joined
·
111 Posts
Discussion Starter #5
Anytime I ever have put my truck in neutral soon after being on the gas, the rpms climb. Is this the same idea?

yep, sounds like mine. will it hurt anything if left for awhile? I'm planning to do my turbo in the next month and would assume i'll have to have the chip reburned anyway?
 

·
Registered
Joined
·
14,569 Posts
Mine's done it for a long time. I don't think it's going to hurt anything. I just have to wait until it calms down to go back into gear.

I have an auto though.
 

·
Registered
Joined
·
198 Posts
Mine has done the same thing since I first installed my DP F5. I talked to Jody about it and he said its not gonna hurt anything, its just that the IPR is not dumping oil fast enough on the shift, so the ICP spikes up.
Now that I have put in hybrids and got my chip retuned, it doesn't do it at all.
Its all in the tuning
 
1 - 8 of 8 Posts
Top