Ford Power Stroke Nation banner
1 - 3 of 3 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter · #1 ·
We finally got some rain the other day here in central Texas and I had to use my 4x4. I then drove 3 hours home from my ranch and when I got home, I noticed some grease had come out of the right hub (auto locking dana 50 in f-250). It didn't look like much had come out, and I never heard any noise coming from the hub. I took off the little cover with the three torx bolts holding it on and didn't notice any metal shavings or any grease seeping there (the grease had come from under that cover.) It also doesn't seem to be leaking any more grease from there. I don't think all the grease came out, because there are just a few specks on the wheel/tire.

Am I about to lose a hub? Do I just need to repack the bearings? If so, how do I do that?
 

·
Registered
Joined
·
133 Posts
Jack up the side you're talking about. Grab the top and bottom of the tire. Attempt to wiggle the tire in/out. If there is play, it'd be worth it to tighten the bearings up.

The grease could have worked out because some water could have gotten into the hub.
 

·
Registered
Joined
·
115 Posts
the large oring between the cap and hub could also be flattened and may need to be replaced. my truck is doing the same thing and i will change those orings soon.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top