Ford Power Stroke Nation banner

1 - 20 of 24 Posts

·
Registered
Joined
·
691 Posts
Discussion Starter · #1 ·
Got my buddy to take some readings using his scanner today heres what i found out

Pull 2 codes at WOT
P0238 turbo boost sensor a circuit high input
P1211 icp high or low

ICP readings at WOT
Duty cycle 65.1%
pressure 13.36 mpa 17 when i let off of WOT
pressure V - 2.53v

manifold guage pressure at WOT 170kpa

whats all this mean? weak HPOP?

what else should i check?
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #2 ·
1 megapascal = 145.037738 pound-force/square inch (PSI)

13.36 x 145.038 = 1900psi ;(
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #3 ·
where is the icp and ipr sensor located?
 

·
Registered
Joined
·
110 Posts
Try this.
 

Attachments

·
Registered
Joined
·
691 Posts
Discussion Starter · #5 ·
So the p1211 says the ipr could be bad
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #7 ·
Icp pressure was 13.3mpa so I'm guessing that comes out to 1900 psi at wot
 

·
All done now
Joined
·
22,483 Posts
Way low.

Good write up cleaning the IPR.
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #9 ·
im gonna pull the ipr and icp i know the ipr is on the back of the HPO res where is the icp?
 

·
All done now
Joined
·
22,483 Posts
Right next to it on the driver side head.
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #13 ·
out of the 2 cost effective options out there im considering an adrenaline or a terminator modded 17* any opinions on these?
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #14 ·
Just talked to a buddy over at international he said it could be leaky injector o rings as well
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #15 ·
Talked to bill over at dieselsite about the adrenaline he mentioned that there may be a tuning issue since I'm only showing a 65% duty cycle. 65 is the limit set by stock programing but I'm running the TW 100hp performance setting.
 

·
All done now
Joined
·
22,483 Posts
I would call Tony and talk to him.
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #17 ·
Called Tony waiting for a reply. I also unpluged the icp and went for a drive. The truck runs exactly the same. And I mean it runs good I just think it should be faster.
 

·
All done now
Joined
·
22,483 Posts
Sometimes it takes a while to get back. He has a regular full time job. Tuning is his fun, part time job.
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #19 ·
Yea I get that I just want this fixed yesterday. I'm half tempted to send the chip to php for the reburn
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #20 ·
went by international and got a new ICP sensor not much has changed seems to run alttle smoother and the pedel feels alittle different
 
1 - 20 of 24 Posts
Top