Ford Power Stroke Nation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2004 6.0 stock. A couple days ago I was driving along, when suddenly my radio went out. I looked and all my gauges had "pegged" as if I had turned the ignition off. The battery light also came on. I did not lose any powere to the engine. Headlight and wipers still worked. Any ideas???
 

·
Registered
Joined
·
4 Posts
Your alternator is toast...Had the same thing happen to my old 04...Your running on strictly battery power now..Your batteries will die a quick death and at same time ,you're damaging your FICm and injectors..
 

·
Registered
Joined
·
706 Posts
Your alternator is toast...Had the same thing happen to my old 04...Your running on strictly battery power now..Your batteries will die a quick death and at same time ,you're damaging your FICm and injectors..
:whs:
Do not drive the truck until you have the alternator tested/replaced, i would also use a trickle charger and juice those batteries back up to full power!!!
 

·
One of a kind
Joined
·
2,198 Posts
Your alternator is toast...Had the same thing happen to my old 04...Your running on strictly battery power now..Your batteries will die a quick death and at same time ,you're damaging your FICm and injectors..
x2
 

·
burning mine saving yours
Joined
·
183 Posts
x3, same thing happened to me and my gauge cluster. I trickle charged both batteries overnight and the following day replaced my alternator. Problem fixed. I knew if I pushed it ficm can die, and then it gets $$$$$.
 
1 - 8 of 8 Posts
Top