Ford Power Stroke Nation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
have a higher tick than usual fairly new to psd wen cold it snaps a little louder new filter 2 days ago is it possible I have bad injector? 10 degrees blok heater plugged in for an hour started right up any help appreciated
 

·
Registered
Joined
·
708 Posts
Very possible, are you able to post a video with the sound?
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
cannt upload a wav file will try a video have to charge camera thx mayb tues. b4 post thx thanks in advance is it possible to use tooo much anti gel?
 

·
Registered
Joined
·
708 Posts
I'm not too sure with that, as I live in Virginia and it never gets cold enough to have to use that. I would imagine it would be possible to use too much, but I would think you would have to put in a whole lot of anti gel in an almost empty tank of fuel to have an effect, but like I said, I'm not too positive on that one.
 

·
Registered
Joined
·
49 Posts
To much anti gel? How much you put in? What are you using? I use power service 8 oz to 25 gal per label on bottle. I haven't had any problems with a little extra but I don't go using a bottle per tank I try and stick with what it says to use pre gal

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
27 Posts
Discussion Starter #6
think I found tick : belt tensioner cannt get bolt out rh/lh thread? filter issue was bad fuel thinking a haigh bio concentrate thx to all for reply and help
 

·
Registered
Joined
·
708 Posts
I'm pretty sure all the pulleys are right hand threads
 
1 - 8 of 8 Posts
Top