Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
'03 F250SD
Joined
·
38 Posts
Discussion Starter #1
I need some more experienced advice here before this gets ugly and expensive. I have an '03 6.0l with 94k on it. I put an Extreme tune from Eric on it 5K ago, changed iol and fuel filters 3K ago. Runs Great. A week ago I'm at a light and it starts a stumbling idle, varying about 300RPM, then it was rough on acceleration from the light (almost like it was dropping a cylinder off and on). Then it stopped, I couldn't duplicate it. It has since done this 3 more times with no common factors I can come up with. I was beginning to get worried about injectors and other things till today. I hit the key for the plugs and heard the fuel pump varying. 3 times I did it and sometimes it was weak sounding, then strong, etc... almost sounds like its got a loose connection and sometimes not getting full voltage. I'm no genius, and I'm not real familiar with the 6.0L yet, but does this sound like a fuel pump going bad? I drive alot of desolate roads each week and would REALLY not like it to die out there! Any help to save me time and money would be greatly appreciated!
 

·
Registered
Joined
·
48 Posts
Did the buzz slowly get weaker during the WTS cycle? If so, are you certain the buzz was coming from under the vehicle at the HFCM, or may it be coming from under the hood?
 

·
'03 F250SD
Joined
·
38 Posts
Discussion Starter #3
Coming from the frame rail one, where the filter is. The one that runs for about 30 seconds when you turn the key. I've never noticed it sounding like that before. It's always been a steady hum before and after it burps. I took it for a few short easy trips today and twice I backed out of a parking spot. when I shifted to drive and touched the gas it stumbled for a split second, then lurched, then it was fine. I rarely run it hard, and I haven't had any other signs of problems.
 

·
'03 F250SD
Joined
·
38 Posts
Discussion Starter #4
I've got a better than average mech background, but not with diesels. So I'm not that familiar with some of the specifics of the 6.0L. I can R&R and troubleshoot anything within reason, but I don't want to pay someone to troubleshoot if I have no idea where to even point them, especially with these weak symptoms.
 

·
Registered
Joined
·
1,856 Posts
Sounds like you have air in the fuel line, but if it's all stock, it should purge itself out...
Are the filter caps tight? (Not sucking air?)
Is the tank full?
The rough idle always seems to be injectors though...or a chaffed wire harness.
 

·
'03 F250SD
Joined
·
38 Posts
Discussion Starter #6
I changed the oil and haven't had any problem since! I was running Mobil Delvac1300 15w-40 and it only had 4800mi on the oil when I changed it. That means it was breaking down at about 4k! I went back to Rotella, never had a problem with it before. :eek::mad:
 
1 - 6 of 6 Posts
Top