Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
got a 1999 ford f250 with 235000 miles on it. was running fine after i replaced the bad alternator and battery when i bought it but now all of a sudden i have a new issue just looking for some input before i start throwing money at it. truck fires right up but runs really "lumpy" so i let it sit for like 10 minutes before driving it. once the idle smooths out i can drive maybe a mile or two before the truck just shuts itself off. it takes a little starting fluid to fire it back up and blows out bluish white smoke and then runs fine for as long as i run it. the smoke smells like pure unburnt diesel. im thinkin the injector pump pressure regulator or injectors ? what ya think? thanks
 

·
Registered
Joined
·
4,955 Posts
if it smells like raw diesel, i would not drive it long. Sounds like you may have an injector that is leaking, or gets stuck when cold. Are there any codes? Could be CPS related also. Rough idle cold could also be glow plug related. Does it have any issues starting cold? Are glow plugs and injectors original?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
it had issuses starting when it was like 40 above but after i replaced the alternator and battery it starts fine now even down into the 20's (know that not that bad but its texas). everything is original other than the air intake its a custom one that once i get outta the army i plan on replacing with something more reliable but it does have a k&n filter inside a pro comp box so its kinda just jimmy rigged and a diesel shop down here in texas says they went thru the truck and loved it so i stopped dealing with them lol
 

·
Registered
Joined
·
853 Posts
DO NOT USE STARTER FLUID
 
1 - 4 of 4 Posts
Top