Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
I changed the filters and replaced the fuel pump that had gotten weak. Now it will run great for a little while then shut down. Then after a prime start up like it’s starving for fuel and sputter then shut down. When it’s running good it will for a little while then stumble and shut down. When I check there’s fuel in the bowl. Could the pickup be bad or a bad tank of fuel cause I have a puff of white smoke at start up
 

·
Registered
Joined
·
179 Posts
I'd guess the pickup has failed or clogged. Time to drop the tank, or raise the bed, and take a look. Don't mess up the sending unit, they're very expensive. If the pickup failed you might consider using a sump instead of the stock pickup.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
I was afraid that was going to be the issue 🤦🏻‍♂️ Good thing I just filled up! Well I guess the misses picked a good weekend to go visit her best friend. Guess I’ll pull it and have it cleaned, wouldn’t make any sense not to do that with it out.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #4
So I dropped the tank the pickup had come off. Replaced it put everything back together and then it started running like it was fuel starved. Could I have got air in the system, primed it several times but still. Also it blew white smoke out the pipes. It’s idling a little ruff also, should I just let it sit idling for a while possibly?
 
1 - 4 of 4 Posts
Top