Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
super tuner
Joined
·
164 Posts
Discussion Starter #1
I purchased 2 sets of hids for my truck one for fog and one for hi/lo. high lows work fine but neither of the fog lights illuminate. fuse 43 is good. only one fog light worked when stock bulbs were in I figured the other one was out due to just a bad bulb,now neither of them illuminate. any ideas? thanks.
 

·
super tuner
Joined
·
164 Posts
Discussion Starter #2
ok reversed polarity and one fog came on. The light that was originally out when hids were not installed is still out. could the harness have an open in it?
 

·
super tuner
Joined
·
164 Posts
Discussion Starter #3
I installed a new harness and they work fine now. Old harness had copper strands exposed so I can pretty much guess what the inside of the wiring looked like. 38 dollars later from ford I have a brand new fog light harness.If anyone is looking for a nice set of HID's for a decent price, check out hidextra.com, great service and great products. I got 2 sets of 55w 8000k HID's and man they are bright. Paid 179 all together which wasnt bad compared to some others.
 

·
super tuner
Joined
·
164 Posts
Discussion Starter #5
I tried the cheaper sets but they were no where near as bright,but if they work for what you want then hell yeah 40 bucks a piece is awesome. I replaced a ballast on one set and got a year out of the bulbs on the other set I had that were under 100 dollars. I heard about these guys and gave em a shot,so far theyre awesome.
 
1 - 6 of 6 Posts
Top