Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
969 Posts
Discussion Starter #1
hey guys , i went to check the fluid levels on my 97 250 4x4 zf5, the filler plug is striped out, the 3/8 ext. just spins inside the plug. i borrowed a set of screw extractors and drove the 1/2 one in as far as it would go, put a socket on it and when i put some pretty good pressure on it , the extractor just comes off.can the transmission case be damaged by hitting the plug area too hard? seems to me that i could drive the extractor in a little more but im afraid of breaking the case. i am thinking of putting a bolt on the plug and spot welding, has anyone tried this? sorry for the long post, any help would be greatly appreciated.
 

·
Registered
Joined
·
3,383 Posts
Bummer I know this does not solve getting the plug out but you always fill throught the top. If you check my sig photos in truck folder there is right up on putting in a short shift and that will help in getting the top off. Also recommend using Redline MTF it ia awesome fluid
 

·
Registered
Joined
·
969 Posts
Discussion Starter #3
thanks for the input, but i can see at least 2 problems going that route. 1-is probably 30 min. at least taking the top off and putting it back on ( hopefully not breaking anything in the process) 2- not knowing when the tranny is full? i just want some advice on how to remove the plug without breaking something.
 

·
Registered
Joined
·
3,629 Posts
do you have access to an air chisel? sometimes you can spin it with that. before welding, I'd try to heat the case up, then try the extractor again. welding is an option but have to be very careful not to weld the plug in place.
 

·
Registered
Joined
·
81 Posts
I had the same problem in my old F150. I never used those screw extractors before and when I did the extractor it just came off. My buddy came over and tried, and it came right off. Im not sure if there is a trick to using them or not, but my buddy always uses them and he got it to work for him, whereas I failed.
 

·
Registered
Joined
·
969 Posts
Discussion Starter #6
thanks guys for the help, retried the screw extractors again, this time it worked. had to jack the driver side up about 6 in. and use a 3' cheater to break it loose( i cannot believe it was put on that tight) anyways got it done. i went with mobil 1 syn. 3.5 in the tranny 3 in the tc.
 
1 - 6 of 6 Posts
Top