Ford Power Stroke Nation banner

1 - 20 of 84 Posts

·
A Ghost these days...
Joined
·
2,434 Posts
Discussion Starter #1
It doesn't happen till the trans is good and warm (150*-170*). When I put it in reverse, the truck lugs way down like its under heavy load. When I pop it back in neutral, it idles back up.

Trans is a local rebuild with about 10k miles on internals. TC is a PI Stallion with probably 20k on it IIRC. Everything pulls good and shifts are crisp. When the trans temps are under 150* or so, I dont have this problem while in reverse.

Any thoughts?

Matt R. (who I bought the trans and converter from), said it might be a leaky Torque Converter Clutch Solenoid in the Valve Body.
 

·
Registered
Joined
·
5,346 Posts
This trans used to do this on and off..... never tried to troubleshoot it. Trans was freshened up and had machining done to the pump to ensure proper clearances and sealing.
 

·
A Ghost these days...
Joined
·
2,434 Posts
Discussion Starter #3
This trans used to do this on and off..... never tried to troubleshoot it. Trans was freshened up and had machining done to the pump to ensure proper clearances and sealing.
Yea. Its only done it once. But I haven't had it that hot but once. You told me about it when I bought it. So I knew about it ahead of time.....
 

·
A Ghost these days...
Joined
·
2,434 Posts
Discussion Starter #4
TTT.

I want this thing fixed before I do a whole lot of towing and get the fluid good and hot.
 

·
Registered
Joined
·
666 Posts
mine does the same thing..maybe its the PI TC?

on edit. mine never did it until i did the pi tc and vb.
 

·
Registered
Joined
·
666 Posts
mine does it everytime i put it in reverse from first start up but after i have driven it, not so much
 

·
A Ghost these days...
Joined
·
2,434 Posts
Discussion Starter #10 (Edited)
mine does it everytime i put it in reverse from first start up but after i have driven it, not so much
Im starting to think it might not be the Solenoid in the valve body since your having the issues running a new BTS Valve body.

I dont know anything about the valve body in this trans..... Except that its fairly new I think.


Thomas: Are you having any issues while in Drive?
 

·
Registered
Joined
·
666 Posts
no, just reverse. btw my Vb is BTS.
 

·
Registered
Joined
·
242 Posts
Im starting to think it might not be the Solenoid in the valve body since your having the issues running a new BTS Valve body.

I dont know anything about the valve body in this trans..... Except that its fairly new I think.


Thomas: Are you having any issues while in Drive?
This valve body is a Transgo Tugger 2. ;)
 

·
A Ghost these days...
Joined
·
2,434 Posts
Discussion Starter #15
This valve body is a Transgo Tugger 2. ;)
Thanks. Where you the one that drove GUS before Matt got it?

Did it only do it to you when it was hot?
 

·
shake and bake baby!!
Joined
·
355 Posts
buddy has an 01 that does the same thing. trans was rebuilt and torque converter went out. installed new pi converter and installed the spring in the pump that came with the converter. now whenever its warm she stalls in reverse. pi techs told him that pump was possibly leaking. any thoughts before he throws a pump at it?
 

·
Former Ford Trans Engr.
Joined
·
3,060 Posts
Locking in reverse indicates low pressure. It could be the pump, or it could be a leak elsewhere.
 

·
A Ghost these days...
Joined
·
2,434 Posts
Discussion Starter #20
Locking in reverse indicates low pressure. It could be the pump, or it could be a leak elsewhere.

The last time this trans was gone through, the pump was machined to bring clearances back into spec. Mark, why does it only do it in reverse?
Yep. She is still doing it. I haven't wanted to take it to the shop till I kinda know what is wrong....
 
1 - 20 of 84 Posts
Top