Ford Power Stroke Nation banner
1 - 18 of 18 Posts

· Going Crazy
Joined
·
1,533 Posts
Re: Fass Pump

that doesnt look good...... i have been through three fass pumps now in probably about the same miles as you have.....
 

· OEM Moderator
Joined
·
10,109 Posts
Re: Fass Pump

Is the pump isolated from the fuel on the FASS. That looks damn ugly where are all the wear particles from?

I move your post to aftermarket and edited the title to make it more descriptive Jason.
 

· Registered
Joined
·
936 Posts
Discussion Starter · #7 ·
Re: Fass Pump

Is the pump isolated from the fuel on the FASS. That looks damn ugly where are all the wear particles from?

I move your post to aftermarket and edited the title to make it more descriptive Jason.
Thanks Tom, what happened was the fuse melted as I was driving. So I put a new fuse in and with in seconds it would get burning hot so after I checked all the wiring I pulled the pump. Pulled the pump checked it and figured the metal particles were causing it to short so I cleaned every thing reassembled and truck ran fine for about 5 min then melted another fuse :doh:. Got one coming in the mail.
 

· OEM Moderator
Joined
·
10,109 Posts
I thought about that but look where the wire connects to the brush and the armature is not grooved.
 

· Village Idiot
Joined
·
8,222 Posts
Soundsl like your were out in the middle of nowhere and did what you could to get home to me....:poke:
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top