Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I'm new. yea. I have a 1996 Thomas 3800 international with a T444E motor (7.3). First had a no start. Changed IPR, ICP no help. unplugged CPS pigtail plugged back in and it hard started. yea. went to drive and shut down on acceleration. Replaced CPS. same condition. Checked fuel pressure 10psi at idle but no hard start. Changed mechanical lift fuel pump and now have 30psi. of course changed all hoses with new clamps, clean fuel bowl and fuel pressure relief screen and assembly. Still stalls in gear with acceleration. I can not read any codes. What unsafe signal will kill the motor in gear. I was told it may be water temp sensor reading over heated. Im stuck. That sensor is in the front and can not reach it with out dissembling front end. I also thought of dropping fuel tank but that is no easy matter either. I believe I need 70psi fuel pressure. What would the experts do first?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Oh, it will rev fine in neutral. fuel pressure stays at 30 psi. When geared and motor stops, fuel pressure still at 30 psi.
 

·
Registered
Joined
·
2,861 Posts
On a Ford PSD, you should get a minimum of 25 psi fuel pressure when cranking (minimum 100 rpm crank speed). You should also get at least 40 psi at idle. Maybe check the fuel pressure regulator to see if something might be keeping it hanging open and losing pressure. Cheers!
 
1 - 4 of 4 Posts
Top