Ford Power Stroke Nation banner

1 - 3 of 3 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
Speedometer goes off, ABS light comes on and overdrive light on the shifter flashes on and off... sometimes all 3 at once, sometimes the OD light and the speedo act up together, sometimes the ABS light comes on by itself. Then the speedo will come back on. Fuse #3 USED to blow, but it doesn't any more.

Replaced VVS sensor. No change.

None of these things cause the rig to run any differently. Batteries were not low and it's always started quickly.

Then, this morning, just walking by the rig, I hear this wierd noise coming out of it... a relay going nuts that I trace down to the f57b-14b192-aa relay in the far upper left corner of the fuse box inside the cab.

The batteries are pretty dead right now... I've got a ten amp charger on them.

Any ideas what the heck is going on here? Does the rig need a shrink?
 

·
riverjet
Joined
·
459 Posts
Replace the relay and find the short-to ground on the # 3 fuse first. I have a hunch the relay is hot when the truck is off. Mine had a relay do the same and caused simmilar problems. You need to find out why the #3 fuse was blowing. Shorts don't fix themselves. It may or may not be related to your current problems,but you still need to take care of it and don't put a bigger fuse in.
 

·
Ships Mechanic
Joined
·
9 Posts
I had the same problem with the same exact symptoms about a year ago, it drove me nuts! I replaced the VSS sensor, but it didnt fix it. What it ended up being for me was a loose, shorting wire behind the fuse box under the dash. there a two (If i remember right) big plug assemblys that plug into the backside of the fusebox that contain all the wires that are fused. and one wire, just one little yellow wire had come loose. I re tightened it and we have been good ever sense.
 
1 - 3 of 3 Posts
Top