Ford Power Stroke Nation banner

1 - 20 of 41 Posts

·
Registered
Joined
·
1,278 Posts
Discussion Starter #1 (Edited)
Background info: Jax' 1999 F350 7.3L Engine rebuild . . . .

On Feb 16, 2020, I purchased the Edge Insight CTS2 with the EAS Exhaust Gas Temp (EGT) Probe directly from Edge dealer Thoroughbred. I paid a premium, but that is because I have had a lot of bad luck lately purchasing from Amazon -- I receive Chinese knock-offs that are not as good as the real thing. Amazon lists it for two-thirds of the cost.

I was pleased, at first. There is a lot of data, and it can be downloaded into a computer for analysis. It did okay for about a month, when the EAS EGT probe suddenly began displaying only " . . . " for the reading. Kudos to Edge - when I called, they sent me a whole new EAS probe. The issue resolved itself when I swapped out the probe section.

At the end of May, my EAS EGT probe again read " . . . ". I was not happy, but it was a weekend so I could not call. Two days later, the EGT was reading again.

About a week ago, my RPM (and everything calculated from it) read zero. The dash gauge displayed normally. I waited to see if it would "recover". Instead, the EAS EGT again quit, displaying " . . . ".

Bottom line - there are 10% one-star ratings on Amazon, and I can believe it. While I haven't got through to Edge yet (too many phone calls to handle more at this time), I will make sure they know this is not acceptable.

Caveat Emptor - Buyer beware.
 

·
Registered
Joined
·
5,803 Posts
When buying anything online especially A-Z one has to be careful.

Also remember if the price is quite a bit cheaper than what it can be purchased otherwise then you really have to check it out.

One nice thing about A-Z is their return policy. But even on that I would tell them that the part is defective and not ordered in err. I believe that shipping back to them if it is defective is on them and not on you.
 

·
Registered
Joined
·
1,278 Posts
Discussion Starter #3
Amazon return / replace is only for 30 days. I bought through the edge site, and it was fulfilled by Thoroughbred Diesel. The Edge literature states that you must go through them for warranty.

These kinds of issues on a new computer are definitely substandard.
 

·
PSN intsigator
Joined
·
6,839 Posts
That is poopy, hope to gets worked out for you
 
  • Like
Reactions: Jax

·
Registered
Joined
·
1,278 Posts
Discussion Starter #5
Update today - finally got through to edge. Updated software and total reset on the CST2.

They will send me a cable from the OBDII to the HDMI that plugs in back.

If this happens again, I want a new unit. This is BS.
 

·
PSN intsigator
Joined
·
6,839 Posts
I agree
 

·
Registered
Joined
·
1,278 Posts
Discussion Starter #7
DUMB question - what good is a turbo on a 7.3?

I hardly ever see it get above 1psi. :D
 

·
Registered
Joined
·
629 Posts
Answer:

Unloaded the turbo does almost nothing.

Heavy loaded and the turbo gives you better volumetric efficiency.

I don't often see the turbo go above 5 psi when daily driving. I have a few smallish hills to climb when driving home. But with 19.5k behind the truck I had the turbo humming at 7 to 11 psi the whole trip home and still got 11mpg. Volumetric efficiency is why you see cars going to smaller engines with turbos as while you don't need the turbo the little engine can really get terrific gas mileage, but when you need the power the turbo will kick in to get you over the hill.
 
  • Like
Reactions: Jax

·
Registered
Joined
·
5,803 Posts
DUMB question - what good is a turbo on a 7.3?

I hardly ever see it get above 1psi. :D

Come up the mountains and haul a load and you will see where a turbo shines.
 
  • Like
Reactions: Jax

·
Registered
Joined
·
1,278 Posts
Discussion Starter #10
Well, yeah, haven't done much of that yet.
 

·
Registered
Joined
·
1,519 Posts
Remember the early diesels that didn't have turbos, with the trail of black smoke that would make a freight train envious? On a hot night you could watch the flame out the stack as that fuel ignited ....

To put it in layman's terms, the turbo uses the heated exhaust flow, ( waste energy), to force feed air to the combustion chambers. So you can actually burn all that fuel you are getting. Even 1 pound over atmospheric pressure is a big difference.

Now up in bugman territory, where the critters are wild and the air is thin, the problem is exacerbated exponentially, without a turbo about all a diesel is good for is making heat and smoke.

Sent from my E6810 using Tapatalk
 

·
Registered
Joined
·
1,278 Posts
Discussion Starter #12
Now up in bugman territory, where the critters are wild and the air is thin, the problem is exacerbated exponentially, without a turbo about all a diesel is good for is making heat and smoke.

Sent from my E6810 using Tapatalk
:ROFLMAO:

I just find it interesting how little the Turbo kicks in. I believe that may be my driving, right? I don't "get on it" but run a steady acceleration.

Just find it humorous that I paid for that fancy-pants turbo and it doesn't work much. I hope to climb into CO this fall, though.
 
  • Like
Reactions: Blue-Truck-Nut97

·
Registered
Joined
·
629 Posts
Ain't that the truth Blue... I drove my dad's old 87 with the naturally aspirated 6.9L diesel in it. Good motor but smoky under a load. I remember a time pulling a trailer coming up a hill with an on ramp with cars trying to merge. I let off the throttle for a mini-van that I know I can't get ahead of, but the numb skull slows down. So I slow a bit more hoping that he'll/she'll get the message and nope! They slow down again! I give up at this point (I doing 35 mph now) and drop the truck into 2nd gear and stomped on the go petal and just let the engine wind up. I did the same thing in 3rd and 4th before looking in the side mirror. I created a SOLID cloud of black smoke and cars on the freeway are merging left to avoid getting swallowed up by it. A match probably could have ignited the mess. Fun times.

Cj
 

·
Project Shamu
Joined
·
2,854 Posts
Back on track, what happened with your CTS2? Im debating on the CTS3 right now...
 

·
Registered
Joined
·
1,278 Posts
Discussion Starter #15
Back on track, what happened with your CTS2? Im debating on the CTS3 right now...
They sent me a new cable that goes from the OBDii to the main unit. Unfortunately, it is hot these days (hitting 97-100°) and I haven't put it in yet. I really should put it in without running it to see if it works.
 

·
Registered
Joined
·
1,278 Posts
Discussion Starter #16
After I typed the above, I was thinking what a lazy #$%^&*() I've become. I went out and plugged in the new cable. It now reads the Engine Gas Temp again and everything.

I will need to drive it around since the RPMs quit reading for no good reason. They also began reading again for no good reason. We shall see.
 

·
Project Shamu
Joined
·
2,854 Posts
Looking forward to hearing your results. I'm wanting to sell all my analog gauges and buy a CTS3 with the EAS addons, but don't want to have a ton of problems.

I've read the CTS3 is a big improvement over the CTS2, I wonder if they have addressed a lot of the problems?
 

·
Registered
Joined
·
1,278 Posts
Discussion Starter #18
Yeah, I sure wish they had come out with the CTS3 a month earlier.

I don't understand how it can have "problems". The computer (CTS) works, or it doesn't. It simply takes the readout from the OBDii and displays it graphically. It also saves it in a data table so you can download.

I can believe a cable once (EAS cable). Now the other cable? They are running out of other things to blame it on.
 

·
Registered
Joined
·
1,519 Posts
Hey Dan you might hit up JCart, if I remember correctly his son had a lot of problems with his, but I'm fuzzy on the details.

Sent from my E6810 using Tapatalk
 

·
Registered
Joined
·
1,278 Posts
Discussion Starter #20
I sent this to CTS just now.
Dear CTS Tech -- Please share this with your sales folk.

I received the new OBDii to HDMI cable and installed it enough to check out the operation. In other words, I did not run it properly through the dash, tie it up, and etc.

While waiting for the new cable, the CTS2 stopped showing the RPMs (and load and ...) again, and just as whimsically began working again. It never showed the EAS EGT.

The new cable seems to work. It sees the EGT and everything else came up.

HOWEVER -- if this happens again, I want a new unit. I paid over $600 for this darned thing, going through YOUR site (you sent me to Thoroughbred) to be sure I wasn't getting 3rd world crap on Amazon. What I have is sorely disappointing.

I have rebuilt my truck -- engine, transmission, drive shaft, rear end. I bought your system to help me take care of my investment, and it has failed several times. Thank you for the great support, but that does not a working unit make.

Please understand this if I have to contact you again.

Regards,
{Jax}
 
1 - 20 of 41 Posts
Top