Ford Power Stroke Nation banner

1 - 11 of 11 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter #1
Is this possible, or is my sensor dead and lying to me? I checked it with my AE and am getting P0470 & P0478. The truck runs fine but the SES light is on. I want to delete the EBPV eventually when I take turbo out for a rebuild. Any words of wisdom as to how to proceed?
 

·
Registered
Joined
·
129 Posts
It should read the same as the MAP, when key on, engine off.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #3
MAP is reading 14.1 psi and EBP is reading 43.97 psi with KOEO. Is this just a sensor issue or bigger?
 

·
Smoke 'em if ya got 'em.
Joined
·
145 Posts
Well if your engine isn't running then there is a pretty high chance that you aren't generating any backpressure.. It should be reading the same as MAP, so that points to a faulty sensor.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #5
You make it sound so simple! Lol, my brain is mush right now! I don't think my valve is stuck because my truck is running fine so I'm not sure if ill replace sensor or not since I want to delete the ebpv anyway.
 

·
whistle tits
Joined
·
3,498 Posts
To the o.p., the ebpv and ebps are not the same thing, and aren't too terribly related. Your issue lies within your ebps and not your ebpv
 

·
Registered
Joined
·
126 Posts
Discussion Starter #7
You probably right, I was just using ebpv as a general term. I was just hoping it was the ebp sensor that was giving me troubles not my ebp valve. I would much rather take the tube off the front of the motor and clean or replace the sensor up front rarher than to have to take the turbo etc off to fix the valve if it were the problem.
 

·
Registered
Joined
·
164 Posts
sorry to jack this thread but i have a quick question regarding the ebps. i broke mine trying to unplu it so i just ziptied the plug out of the way. am i hurting anything by running it like this and is there anyway to delete or bypass the sensor. i have ebpv deleted
 

·
whistle tits
Joined
·
3,498 Posts
sorry to jack this thread but i have a quick question regarding the ebps. i broke mine trying to unplu it so i just ziptied the plug out of the way. am i hurting anything by running it like this and is there anyway to delete or bypass the sensor. i have ebpv deleted
You're not hurting anything. I got rid of mine on my 2002, and never noticed it was gone
 
1 - 11 of 11 Posts
Top