Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
Hey guys...Need some help here if you can! My truck out of the blue started to run real rough just after starting it, a few min later she died. It appears to be a HPOP problem...IPR is 85% at idle if it starts and takes forever to build 500psi until it starts. When the oil is hot it won't start and it won't go above 325psi while cranking. I put in a new IPR and no change...there was no metal on the screen of the old one either...it was clean.

I made an adaptor to go into the HPOP rails under the valve covers and made a pig tail to close the IPR. Air test on left bank shows only a small leak under HPOP cover. Air test on right bank shows no leaks with ipr closed. But a huge air leak from the standpipe/branch tube connection area? I didn't think it would matter wether the ipr was closed or not for a leak there? I pulled the hpop cover and am about to pull the hpop to dig deaper.....should I pull the rail on the pass side and pull out the stand pipe to check? Im prety deap in her and im not really sure where to go from here to identify the problem.
 

·
Word
Joined
·
608 Posts
Check the fitting that connects the HPOP to the branchtube, early 6.0's had a 2 piece connector fitting that would leak ( it looks like 1 piece but it's actually 2 pieces crimped together with an o-ring), they have a new style 1 piece connector fitting...a lot of HPOP's were replaced that weren't bad due to this fitting...
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #3 ·
Thanks...I went to the dealer and got a STC fitting update kit just in case that was it. I'll get a chance tomorrow to check it out.... I gave the parts guy the VIN number and he said he didn't need it since they replace a ton of these fittings on the HPOP and he knows what I need... Now thinking about it I thought the pre 05 didn't use a STC fitting? Because the 03-04 used some other kind of fitting. Will the standard STC fitting kit work on my early 04 or do I need a different part/kit for the HPOP fitting?
 

·
Word
Joined
·
608 Posts
The pre 05 didn't have the STC fitting, which is a 1 piece fitting, they had a 2 piece crimped together fitting that was notorious for leaking. The STC fitting will work on the 03-04 models, Ford actually has a TSB about replacing the 03-04 model fittings with the STC fitting when you have to replace them...it's a direct swap over, nothing else needed.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #5 ·
OK thanks! for once I got the correct part the first time to the dealer.

I tried to check the standpipe to branch tube connection...I'm assuming there is an o-ring seal there? For the life of me I could not get the HPO "quick" disconnect braided lines off of the rail or the standpipe! is there a trick? does the collar get slid up towards the fitting on the hose or slid down away from the hose?
 

·
Word
Joined
·
608 Posts
They make a disconnect tool for the lines and it's very useful...it's hard to explain how you can get them loose without seeing it done, you have to push the collar forward while pushing in on the center ring of the collar then pull back on the coupler while still holding pressure on the center of the collar, if this makes sense...
 
1 - 6 of 6 Posts
Top