Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
stoneykegonsa
Joined
·
40 Posts
Discussion Starter #1
Now that the warm weather has returned truck is not shifting from 1st to 2nd all the time some times it needs to be done manualy this is only a problem after trany has warmed up eany ideas thanks
 

·
Demon Dually
Joined
·
5,140 Posts
Are you getting a flashing O/D light? If so then you need to have the truck hooked to a scanner. I would be suspect of a bad solenoid pack. I just put a new stage 3 trans in my truck and the company I bought it from had gotten a bad solenoid pack that they put in then when I put the trans in I had to have them send me two more until I finally got a good one. They ended up ordering a new one from ford for me. The reman company they were using named Recon has very poor quality control. I wouldn't get one from them. Moral of the story is that ypu either have a bad solenoid pack or an internal seal failure. The pack is easy to change. The seal would require a tear down though unless your valve body is sticking in which case you could swap out valve bodies.
 

·
Registered
Joined
·
421 Posts
I also suggest you get your codes read... It does not necessarily require the OD light to flash in order to set a code. It probably is the solenoid pack as speeddemon suggested..
 

·
Registered
Joined
·
149 Posts
i had a similar problem last year.had to start out in 2nd gear then to drive.turned out to be the first gear shift solenoid.good luck.
 
1 - 5 of 5 Posts
Top