Ford Power Stroke Nation banner

1 - 14 of 14 Posts

·
FGilpin
Joined
·
7 Posts
Discussion Starter #1
I have a '97 F-250HD 4X4. The trans was rebuilt less than a year ago, and a bigger cooler was installed. I also have a Mag-Hytec pan on it (which I see reading the forums was probably a waste of money). When I'm driving around town, it gets up to about 180. However when I towed my 5th wheel last time, it got up to about 230. It was 65 degrees tops outside. Do I need a bigger cooler? I saw the pics of the tru-cool installation behind the bumper, thought it was pretty slick. Would this be a good idea?

Thanks
 

·
Registered
Joined
·
4,810 Posts
Way to hot!! Something is wrong if you have those temps and a big cooler..additional info..needed
 

·
Former Ford Trans Engr.
Joined
·
3,060 Posts
Where is the temp sender located?
 

·
FGilpin
Joined
·
7 Posts
Discussion Starter #5
It only gets worse. I drove about 40-50 miles yesterday, and it got up to 220 without a trailer. My water temp gague isn't working right, so I got a new sensor today. My trans temp sensor is in the pan (the Mag=Hytec pan has a place for the sensor).
 

·
Registered
Joined
·
2,438 Posts
sounds like your cooler is plugging up thats what mine did befor the trans died. pull yout cooler return line and see if you get a quart in about 1 min @ idle
 

·
FGilpin
Joined
·
7 Posts
Discussion Starter #10
I got under the truck this afternoon. I've been looking at the engine cooling system because the engine temp. gauge isn't working right. I found that the shop I had do the work went straight to the cooler, and bypassed the radiator cooler. I'm going to take the truck back to him because the transmission work he did is still under warranty.
 

·
OEM Moderator
Joined
·
9,381 Posts
Not very impressive work by the trans shop. I assume they were worried the cooler was full of junk from the failed trans and took this route to address that.
 

·
Registered
Joined
·
4,810 Posts
Dang..must have been a tight fit..which IC did you use..I couldn't fit in in with my Tapercore.
 

·
PSD
Joined
·
958 Posts
it was a tight fit. I had to cut some plastic knobs that were in the way that were on the grill support. other then that it JUST fit. I/C is 00' 7.3L with hypermax tubes.
 
1 - 14 of 14 Posts
Top