Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
498 Posts
Discussion Starter #1
I have a 97 f-250 CCSB 7.3. The truck has 250k miles, but I was told the trans was replaced 3k miles ago. It looks very clean under there (except for the trans fluid leak on all the bolts I am assuming from the pan bolts not being tight enough). Anyways it likes to hold first gear for ever until I either put my foot in the throttle heavy or back off on it. It also likes to shift hard between 3rd and od, and gets the flare sometimes from the TC locking up. This is driving me crazy after I probably could have bought a 6.0 with half the miles for the price I paid for this truck. I am in texas right now, but I am driving back home to california in july for 2 weeks, then heading to north dakota for 3 years. I wont be able to work on the truck much here in texas, and I am not sure how it's going to be in north dakota.

Anyways, I was wondering what you guys would recommend to fix this? I have read some stuff about possibly a shift kit of a valve body. I am kind of short on cash since uncle sam doesn't pay me too much so I can't afford a lot. Down the road the plans are for a bigger turbo, injectors, tune, new DP to match the exhaust, intercooler, and maybe some other things. Would prefer to not have to buy parts twice either though.


I don't have a lot of time to search after class so sorry if this has been covered before :doh:
Thanks,
Mike Smith
 

·
Registered
Joined
·
105 Posts
I have a 97 f-250 CCSB 7.3. The truck has 250k miles, but I was told the trans was replaced 3k miles ago. It looks very clean under there (except for the trans fluid leak on all the bolts I am assuming from the pan bolts not being tight enough). Anyways it likes to hold first gear for ever until I either put my foot in the throttle heavy or back off on it. It also likes to shift hard between 3rd and od, and gets the flare sometimes from the TC locking up. This is driving me crazy after I probably could have bought a 6.0 with half the miles for the price I paid for this truck. I am in texas right now, but I am driving back home to california in july for 2 weeks, then heading to north dakota for 3 years. I wont be able to work on the truck much here in texas, and I am not sure how it's going to be in north dakota.

Anyways, I was wondering what you guys would recommend to fix this? I have read some stuff about possibly a shift kit of a valve body. I am kind of short on cash since uncle sam doesn't pay me too much so I can't afford a lot. Down the road the plans are for a bigger turbo, injectors, tune, new DP to match the exhaust, intercooler, and maybe some other things. Would prefer to not have to buy parts twice either though.


I don't have a lot of time to search after class so sorry if this has been covered before :doh:
Thanks,
Mike Smith
02: Custom Valve Body needed. A shift kit can't fix wear, sounds like you have some.

Shift kits and related products assume the installer is a professional who knows when more than a kit is needed. Rebuilder should have used a new reuseable pan gasket on a 97 and repaired any stripped pan bolts-- if the pan is the source of the leak. Check pan bolts, only 10-12 ft lbs is the torque spec on your pan bolts.

~
 

·
Registered
Joined
·
4,810 Posts
What other mods? Chip? Did the owner say its always been this way? Maybe the shop that did the trans can reajust it..worth a call. Little more info would be helpfull.
 

·
Registered
Joined
·
101 Posts
I am curious about this aswell cuz i have a 95 bone stock does the exact same thing except it randomly hesitates when shifting into drive. Has anyone else had these problems? what did it take to fix. Thanks
 

·
Registered
Joined
·
498 Posts
Discussion Starter #5
02: Custom Valve Body needed. A shift kit can't fix wear, sounds like you have some.

Shift kits and related products assume the installer is a professional who knows when more than a kit is needed. Rebuilder should have used a new reuseable pan gasket on a 97 and repaired any stripped pan bolts-- if the pan is the source of the leak. Check pan bolts, only 10-12 ft lbs is the torque spec on your pan bolts.

~
Hmm alright I will think about a custom valve body. Rebuilt a trans when I was 13, but it's been a while since I have opened one up lol. I will check the bolts this weekend, I think I should have access to some tools and a lift.

What other mods? Chip? Did the owner say its always been this way? Maybe the shop that did the trans can reajust it..worth a call. Little more info would be helpfull.
Right now it has just an exhaust, everything else is completely stock. I can't go to the trans guy because that was two owners ago (truck was bought then sold quick) and the trans shop is 350 miles away. I am only allowed 250 miles from where I am at now :(

I am curious about this aswell cuz i have a 95 bone stock does the exact same thing except it randomly hesitates when shifting into drive. Has anyone else had these problems? what did it take to fix. Thanks
Yeah my dad said the 97 he test drove, his old 97, and mine all drove like this.
 

·
Registered
Joined
·
498 Posts
Discussion Starter #6
Found out all of my problems was a gold colored thing with superchips written on it. Got a TS chip in and it shifts like a dream now, and truck runs tits!
 
1 - 6 of 6 Posts
Top