Ford Power Stroke Nation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I have a 06 f250 with the 5r110w transmission a while ago I was leaving a stop sign with my tune turned all the way up along with the my chip turned all the way up and spraying meth. When i got into the upper range I lost my tranny "no gears". I checked codes and got codes p0730 incorrect gear ratio, p0756 shift solenoid B performance/ stuck, P2700 transmission friction element A apply time range/performance and P2701 transmission friction B apply time range/performance. I have a new triple disc torque converter in it and is not reading any codes for that plus the input and intermediate shafts are reading correct rpm's. I just replace the O/D clutch solenoid and the Coast clutch solenoid thinking that be it but to no luck. Could it be another one of the solenoids such as the direct pressure solenoid?
 

·
Former Ford Trans Engr.
Joined
·
3,101 Posts
It is a solenoid. You have P0756, shift solenoid B performance/ stuck. That means a solenoid was stuck. This code sets when the TCM commands the solenoid to move and it does not. I don't remember which solenoid is solenoid "B."
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
Po756 Overdrive clutch failed OFF. That is one of them that I had replaced. When I put in gear yesterday after putting in the new solenoids and rev it to about 2000 rpms it's like the truck wants to move but doesn't. Just thinking the EPC solenoid or the direct clutch solenoid is bad but it doesn't show any codes for those.
 

·
Captain Negativity!
Joined
·
3,109 Posts
Unless OBD-2 Theory and operation has changed... 5R110W does not have the ability to isolate a shift solenoid fault from the rest of the mechanical/hydraulic system – all detected ratio errors result in MIL illumination except those attributed to the Over Drive and Simpson On-Way Clutches (which cause Neutral condition failures which cannot be caused by an electrical component).
 

·
Captain Negativity!
Joined
·
3,109 Posts
Po756 Overdrive clutch failed OFF. That is one of them that I had replaced. When I put in gear yesterday after putting in the new solenoids and rev it to about 2000 rpms it's like the truck wants to move but doesn't. Just thinking the EPC solenoid or the direct clutch solenoid is bad but it doesn't show any codes for those.
Did you make sure the screen was put back in place? Truck needs forward clutch to move in 1st gear with selector in OD. If it's cold outside or if it is in tow-haul low/reverse clucth will apply to lock the one way clutch. But OD one way clutch is holding along with low/reverse. So if you aren't moving something isn't holding... Try putting it in manual 1 to use the manual valve to get things applied.
 

·
Captain Negativity!
Joined
·
3,109 Posts
Which screen? I tried to shift through all the gears manually also.
What some like to call the filter. Sometimes the little o-ring likes to stick inside the pump and then when the filter goes back in it doesn't stay.
 

·
Registered
Joined
·
187 Posts
ok hopefully you guys can help me. i just got my reman trans in today and its having bad shiftflair and heasitant in some gears. i cant tell whats wrong with it but im getting two codes p2701 and the other one says soleniod b is stuck on. do you think its a bad solenoid and can anyone point out whick one it is in the solenoid body with a pic?


ps i got this reman trans because i was having problems with direct clutch solenoid and burnt direct drive clutches. now im haveing sort of the same issue. the company i got the trans from says its an electrical issue too look at the wireing harness. has any one hurd of that ?
 
1 - 8 of 8 Posts
Top