Ford Power Stroke Nation banner

1 - 7 of 7 Posts

·
06 FX4,4" Rough Country
Joined
·
101 Posts
Discussion Starter #1
So I recently put a 4" dp and 5" complete system from diamond eye on my truck and it was just about the death of me. The dp fit on fine, the problem was connecting the mid pipe to the down pipe, going from 4-5". For some reason they have 3 adapters that go between the dp and mid pipe to connect them. I had everything perfectly pushed tight together and began tightening the clamps and it just caused a mess. All the cupplings wouldn't cinch down tight and they kept coming loose, finally just getting so bent out of shape they couldn't possibly hold tight. So after 7 hrs my truck was still useless. The next day had to have a friend come weld everything up and now it's fine. Just wondering If anyone else has experienced this bc it was awful!
 

·
Registered
Joined
·
11 Posts
I installed a diamond eye 4" turbo back system on my excursion and I endednup welding it together to cause it kept coming loose. I like the setup and has been trouble free for me the last 4 years.
 

·
Super Moderator
Joined
·
3,401 Posts
I'd contact Diamond Eye to get a better answer on your compliant. I do appreciate giving other consumers a heads up on the issue.

Sometimes bigger isn't always better.
 

·
09 6.4
Joined
·
989 Posts
i always tack weld every joint and never use the junk clamps they include in the package. ive installed several of these diamond eye exhausts and never have much trouble with fitment.
 

·
Big dumb redneck
Joined
·
4,200 Posts
Same kit as you on mine. Fitment is really well, but the clamps are just junk. Had the same issues with Silverline on my old truck. Don't get when they always skimp on hardware.
 

·
Registered
Joined
·
82 Posts
I have the same exhaust and mine is awesome fitment clamps are tight as can be
 

·
06 FX4,4" Rough Country
Joined
·
101 Posts
Discussion Starter #7
Thanks for the feedback, all my fitting was tight. Just bad clamps I guess
 
1 - 7 of 7 Posts
Top