Ford Power Stroke Nation banner

Have you found debris in the HPOP screen gasket


  • Total voters
    49
  • Poll closed .
1 - 20 of 46 Posts

·
OEM Moderator
Joined
·
9,381 Posts
Discussion Starter #1
If you have had your HPOP reservoir off to change a pump or whatever did you discover any debris in your screen on the lower gasket. If you did find debris what was the nature of the debris, metal flake, gasket material, etc. This is related to a thread in the OBS section about adding that screen to OBS trucks with the Dieselsite adapter.
 

·
Crazy Talk
Joined
·
3,537 Posts
after my motor blew i had part of a piston cooling jet in there. i didn have a screen but shows how big of stuff can get up there.
 

·
OEM Moderator
Joined
·
9,381 Posts
Discussion Starter #3
WOW, that is crazy.
 

·
Crazy Talk
Joined
·
3,537 Posts
How the heck did it get through the pick-up screen, then through the oil pump?



Crazy
i would like to know too. if you look at a jet it was the last lil bit of it were it tapers down. o and it didn look like it went through the pump and that pump still looks/works great.
 

·
OEM Moderator
Joined
·
9,381 Posts
Discussion Starter #8
Good info so far. I hope a few more people will vote.
 

·
Registered
Joined
·
2,438 Posts
black stuff
 

·
Registered
Joined
·
319 Posts
:popcorn:

I'll know soon when I replace my pump
 

·
Registered
Joined
·
928 Posts
I've found gunk of some sort on the screens on the 4 or five motors I've taken apart including my own. Did not inspect to close to see what it was, no metal particles, seemed more like the RTV gasket material.
 

·
<<< THE GAUGE WHORE...
Joined
·
12,082 Posts





Get this at every oil change... Normal right???












Kidding... That was after I blew the last motor.
 

·
All done now
Joined
·
22,486 Posts
Get this at every oil change... Normal right???












Kidding... That was after I blew the last motor.
For a minute there, I thought you were talking about HPOP oil change. You mean you really don't change the HPOP oil.:poke:
 

·
Village Idiot
Joined
·
8,209 Posts
Mine didn't have a spec on it...:D
course being an early 99 doesn't have a
screen to catch anything either.

so I have to reply E. none of the above.
but no oiljets or chunks fell out of the res or hpop when they were pulled,
about the best i can tell ya.
 

·
OEM Moderator
Joined
·
9,381 Posts
Discussion Starter #18

·
Registered
Joined
·
374 Posts
Tom,
So folks are responding that don't even have factory installed screens? IE: early 99s and OBS trucks?

What is the point of this poll if it isn't a controlled poll with specific requirements, like that they have a screen? Do you want me to vote 200 times for the screens I've seen? I knew when you posted this that the results would show the majority of guys that change their SCREEN would find debris in them, but if there is no SCREEN, there is no vote.

And to be fair, a known blown motor doesn't apply either.

How about you delete the trucks that don't qualify and you'll get more accurate information. I see several in there that fit that description.

Bob
 
1 - 20 of 46 Posts
Top