Ford Power Stroke Nation banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
2002 dt466e
deadheaded hpop to test, it gets 4600 psi while cranking, but immediately drops to 0psi as soon as cranking stops. ipr is new, and commanded close manually with 12vdc applied to pigtail.. what do you guys make of that?

problem is 333 code when under load or climbing long hills. Icp, injectors, and o-rings are new as well, starts right up whether sitting for 4 days, or hot.

charged oil rail through pop input, left icp in place(didn't have fitting to charge through icp port) plus I figured charging through hpop oil rail inlet, would eliminate the need to command ipr closed. I just used ball valve between shop air and oil rail to see if it would hold any pressure, all the pressure bleeds off in about 10 -15 seconds, and I don't hear any air bleed off.. no oil in diesel, or vice versa.

engine does idle a little rough, new cam sensor(aftermarket just for testing purposes)

Whats you guys opinion? was told that hpop should slowly drop pressure after deadhead, and not just fall off immediately
 

·
Registered
Joined
·
237 Posts
What's code 333 probably a bad hpop
 

·
Registered
Joined
·
4,947 Posts
What brand injectors? I had a set of injectors I put in a dt530 that leaked oil between the armature plates and solenoids when hot causing oil bleed off. It shouldn’t be a big deal your pressure falls out after cranking. When it’s running it won’t matter.

Pull the valve cover and apply air through the hpop feed port on the rail. Look for air/oil leaks.
 
1 - 3 of 3 Posts
Top