Ford Power Stroke Nation banner

1 - 7 of 7 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Well, out plowing snow one night, I was pushing across one of my parking lots, all of the sudden, the door chime dings a couple times, (which alerted me to a thought of WTF is going on) and I look at the dash and it was lit up like a christmas tree, the dial guages all "reset", making a full sweep and then returning to their proper indications, and then I notice that the odometer reads all 8's across it. And has since ceased functioning. All other functions appear normal as for the rest of the dash. Other electrical gremlins have been the delayed accessory relay (power windows, radio, etc) doesn't work, and once in awhile the wipers won't shut off when you turn the switch off, and the overhead trip computer (lariat model) re-calibrates the compass. A lot. About every other day it seems. Any ideas? All the braided and wire grounds appear intact. New Optima yellow tops, and a 250 amp alternator. Can't seem to nail this down.....
 

·
All done now
Joined
·
22,486 Posts
GEM
 

·
All done now
Joined
·
22,486 Posts
On top of the fuse box.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #6
This truck doesn't have a gem. It has a vsm. Does the vsm control the same things as the gem used to? Entire wiring/fuseblock setup is different than my gem equipped '01.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #7
This truck doesn't have a gem. It has a vsm. Does the vsm control the same things as the gem used to? Entire wiring/fuseblock setup is different than my gem equipped '01.
 
1 - 7 of 7 Posts
Top