Ford Power Stroke Nation banner

1 - 12 of 12 Posts

·
Registered
Joined
·
745 Posts
Discussion Starter #1
I know i need to get it on a scanner and data log whats going on. But i will ask for some things to check and see if anybody else has this and fixed it.

Right around 2k RPM i feel a cut out or a miss. At first when i started noticing the problem i thought it might be my foot bouncing on the peddel when hitting bumps and thought nothing of it but it was always in the back of my head maybe somthing is wrong. Yesterday i took it out on the free way and set the cruise and it still does it so i think i ruled out my foot. The truck runs strong starts with no issues and does it in every tune.I have a WW and a Big Head no CEL and my guages seem to stay steady. Just around 2k of normal cruising it shuders not jerky just like i am playing with the exselerator.

Any help would be great;)
 

·
FNG
Joined
·
6,018 Posts
Is this happening at any speed Dale. Or just on the highway?
 

·
FNG
Joined
·
6,018 Posts
Change your CPS
 

·
Registered
Joined
·
745 Posts
Discussion Starter #5
OK.

The worst part is i had my ould truck and all these issues sorted out. Than it ended up totaled. Alot of the stuff i had done on the old i am doing again on the new. It is easier the second time just frustrating. LOL
 

·
Well Hung Member
Joined
·
635 Posts
yea what color is it?
 

·
Registered
Joined
·
110 Posts
I had similiar problems and have been talking with glenn on previous post about tps. Mine went away after a couple of things were done simultaneously. Took tank down and changed out screen at bottom and cleanded filters in pickup(should have just done the mod but at this point I was sick of throwing money at this thing) and blew out all the lines from fuel pump back with brake cleaner and compressed air. Next changed the fuel pump and put a new ICP sensor in. Now no problems to report. Forgot to mention the intank cleaning and fuel line clean out to Glenn.
 

·
Registered
Joined
·
745 Posts
Discussion Starter #9
Thanks every one for the ideas i will be looking at all of this. I think i will go to my local International parts dealer for the CPS and dropping the tank and doing the mod as well as putting my before pump filter water seaperator from old truck on new, once i get the new filter for it.
 

·
Registered
Joined
·
1,053 Posts
in-tank mods are on my list next if IPR don't fix it...lol been throwing money at this truck like there ain't no tomorrow!
 

·
Registered
Joined
·
110 Posts
For International parts I use Santex Truck Center in San Antonio 210-661-8371. They have their best price then let them know you read on one of these forums it should cost (whatever you think it should cost) and see if they'll do it for that price. It worked for me with my bellowed up pipes, they started at 478 and I bought for 418. Big difference. They will ship the same day you buy, I always receive my merchandise the next day UPS.
 

·
Registered
Joined
·
142 Posts
If it was the TPS then you should get a CEL, it can cause this, the CEL will go away when it cuts back in. Another thing is the IDM, it can miss then cut right back in giving the same symptoms. The IDM will get bad enough that the engine will sound like it is being turned off and will die sometimes, it will eventually get bad enough that you can restart it and it will die seconds later. I've experienced both of these. I posted a long troubleshooting post titled something like 'truck died suddenly'. I did the reg return, new ICP, IPR, CPS, injectors, then the IDM. Hope this helps.


Good luck, post what you find to help others.

JP5
 
1 - 12 of 12 Posts
Top