Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter #1
So this is my baby. very well taken care of. Driving home from work today about 25 miles an hour light throttle and the check engine light came on and engine died instantly out of no where.... Pulled off to side of road, replaced the CPS sensor with the gray one, which is the same one that was on it, pulled all neg cables for 5 mins. cranked her over and nothing. She cranks nice and fast but no fire...

On sunday(yesterday) the check engine light came on and it ran rough for 30 seconds or so, i hit the throttle and it was really delayed. then i let it idle out and returned to normal operation. Didn't have a problem with it until it died completely today and no wont start again?

she does not put out smoke when cranking, And i dont think the tach moves, but i just replaced the cps with a new one..

i bought the 187####c95 part cps from I/H

This is my only rig and i have no idea whats wrong with it. She has never ever given me any problems, now this. Any ideas or tests i could run would be greatly appreciated. Can parts stores scan the diesels to pull possible codes etc?
 

·
JFURNER77
Joined
·
404 Posts
I have seen 2 trucks this month w/ burnt VC & UVC harness's.
This will warrant a "no start" if not within specs
-Fuel pressure, bad injectors
-IDM pulse to injector soilenoid
-High pressure oil (1500 psi. warm, 2500 psi. cold)
-IPR, ICP (500-800 psi. to start)
-CPS
-GP system (on cold start)
-Fuses, low batteries, low oil, loose connections, harness&VC burns
-No compression in cylinders
-Faulty PCM/IDM
-Faulty ignition,relay,starter
 

·
Registered
Joined
·
155 Posts
Discussion Starter #4
i think i got lucky it was the #22 maxi fuse under the hood. So i pulled the biggest plug/cord of the fuel bowl which i assumed was for the heater and replaced the fuse, fired right up.
 
1 - 5 of 5 Posts
Top