Ford Power Stroke Nation banner

1 - 9 of 9 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter #1
OK guys was doing some exhaust work under the truck and I saw liquid (relatively sure it's coolant) had been dripping down my starter. Got to looking and it appears it is leaking coolant between the exhaust port on the passenger side head and the exhaust manifold. Cranked it up and you can see bubbles forming at bottom of manifold between manifold and head. I haven't noticed any puddles, discoloration, on my concrete driveway so its not a bad leak. Truck is stock other than exhaust, air filter assembly, and blue spring upgarde motor wise. Has full EGR delete. No liquid visible in valley under intake and I Have Not seen any smoke from exhaust

Any ideas what may be causing this?
 

·
Registered
Joined
·
4,955 Posts
With an EGR delete, if indeed thats where it is coming from, the only way this is possible is through a headgasket, or cracked head/block. Verify its coolant and not fuel. Smell it to be sure. Make sure its not leaking from the EGR delete J hose.
 

·
Registered
Joined
·
218 Posts
Are you sure that the coolant is coming from that location and not up higher on top of the manifold? What I'm getting at is check to see if your leaking from up above, say your degas bottle or a coolant line, and its working its way over to where your seeing it.
Air and coolant coming out of the same leaking gasket hole doesn't sound right.
If not, than I'd agree with Matthewd11 that its prolly fuel.
 

·
Fixing Broken Stuff
Joined
·
2,078 Posts
^^^^ All good advise, I'd do what they say.
 

·
Registered
Joined
·
111 Posts
Discussion Starter #6
thanks guys. looking over everything and trying to determine where leak is.
 

·
"resident smarty pants"
Joined
·
4,360 Posts
Please provide more information ...........

Have you done what was suggested above?

- Do you have an EGR delete?
- verified it is coolant and not fuel?
- verified it isn't the heater valve?
 

·
Registered
Joined
·
543 Posts
DID YOU EVER FIGURE OUT WHAT WAS CAUSING THE LEAK. I HAVE THE SAME PROBLEM.
dude this thread has been dead since 2014... start a new one rather than digging up a skeleton...
 
1 - 9 of 9 Posts
Top