Ford Power Stroke Nation banner

1 - 14 of 14 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter #1
like the title says, i scanned my truck today only to find i have a code. p1670ef. what is this code and is it anything to be concerned about? my truck seems to be running fine. :confused:
 

·
Headwind Magnet
Joined
·
626 Posts
From the 7.3 Library:
PCM-IDM diagnostic communication error EF signal not detected

It means the IDM is not talking back to (providing feedback) to the PCM. I'm pretty sure its only a problem if it reoccurs and is accompanied by some kinda engine problem. If that is the case, it would indicate there are IDM codes stored but the IDM is keeping them secret from the PCM.

I kept getting this code on my truck and it was running poorly. Replaced the IDM and found a bunch of P1200 series codes.
Best,
Jim
 

·
Registered
Joined
·
115 Posts
Discussion Starter #3
so should i just replace the IDM? the truck seems to be running fine, but now youve got me worried, what else should i look for?
 

·
All done now
Joined
·
22,486 Posts
No, clear the codes and see if it recurs.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #5
10-4 if it doesnt come back should i still be concerned?
 

·
Headwind Magnet
Joined
·
626 Posts
This code doesn't cause engine problems but it may mask or hide the cause of problems if/when they develop. If it does not reoccur I would chalk it up to an electrical gremlin and not worry about it. If it does come back and the truck is running fine its up to you whether to replace the IDM. So long as your truck is running fine, there is no hurry to do anything.
Best,
Jim
 

·
Headwind Magnet
Joined
·
626 Posts
Thanks Andy, that is a very good post up to about page 5, then I'm lost! :doh:LOL

Best,
Jim
 

·
All done now
Joined
·
22,486 Posts
Yep, it started out very informative. Then kinda went downhill. I wish somebody would clean it up and leave all of the good stuff in there.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #10
Thanks a lot Andy, thats a great thread. put about 100 miles on it today with no issues and the code has not yet come back.
 

·
All done now
Joined
·
22,486 Posts
just to prove it out. Disconnect the batteries. Betcha it comes back.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #12
why would it come back after disconnecting the batteries???
 

·
All done now
Joined
·
22,486 Posts
why would it come back after disconnecting the batteries???
Because that is what sets that code. Nevermind. Was following a different thread and thought this was it. Disregard my last two posts.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #14
Lol, thanks anyhow Andy.
 
1 - 14 of 14 Posts
Top