Ford Power Stroke Nation banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,250 Posts
Discussion Starter #1
When I put my truck in four wheel and accelerate or go uphill the front end clicks. It sounds like its comin from the hub but I couldn't pin point it. Tried manually lockin the Hubs and is the same don't do it with just coasting just when you put torque on it any ideas?

Thanks kris.
 

·
Registered
Joined
·
252 Posts
When I put my truck in four wheel and accelerate or go uphill the front end clicks. It sounds like its comin from the hub but I couldn't pin point it. Tried manually lockin the Hubs and is the same don't do it with just coasting just when you put torque on it any ideas?

Thanks kris.
I had an old Bronco that used to do that when the hubs were not fully engaged. If i recall correctly i think it was a vacuum issue that caused the clicking. meaning that a vacuum leak was causing the hubs to not engage or disengage fully from time to time. It did make a loud clicking noise that was really noticable like youre describing. I think i jsut had to put it in and out of 4WD until the hubs fully engaged. like put it in 4wd and then drive a few feet and then pull it out of 4WD. I think i did that until the clicking stopped. Again that was an old Full sized bronco not a Super Duty.
 

·
Registered
Joined
·
1,250 Posts
Discussion Starter #4
Yeah the u joints are good there is alot of play in the axle shaft from the axel to the hub where that u joint is tho I no there should be some play but don't no how much, both sides are the same tho. And I also thought maybe a vacume issue but I manually locked em and didn't change anything
 

·
StackinChipsLikePringles
Joined
·
3,085 Posts
You need a new hub. Jack it up and manually lock it and watch your axle or even put something to stop your axle while you turn the tire
 

·
Registered
Joined
·
1,250 Posts
Discussion Starter #6
You need a new hub. Jack it up and manually lock it and watch your axle or even put something to stop your axle while you turn the tire
You've had the problem too? I was thinkin that I called today and my local stealer ship has one on stock so I guess I'll jack it up and try to make sure
 
1 - 7 of 7 Posts
Top