Ford Power Stroke Nation banner
1 - 9 of 9 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
Hey guys, i just recently bought a new to me 2008 f250. Its got the 6.4 powerstroke and today i was playing around with the system check tool. It said "cleaning exhaust filter" and my check engine light came on. Does this mean my truck is in regen? or is it just coincidence that my check engine light came on? thanks for any info!
 

·
Registered
Joined
·
48 Posts
CEL has nothing to do with regens. Speaking of regens, when you get the "cleaning" message you should drive it till complete (possibly freeway).
As far as the code/s you should find out what that's about.
Hopefully its something intermittent and will come off in time.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #3 ·
The code that check engine light was on for was p0000.
I have no clue what that could be
 

·
Registered
Joined
·
270 Posts
Not sure about that code. Could be that it needs to regen and won't: bad DPF and/or sensors. But, those codes are in the p240s. Notice any grey or white smoke?
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #5 ·
Had a little white some once about an hour before the check engine light came up
 

·
Registered
Joined
·
270 Posts
Still running without any problems? Most on here will tell you to stop/take it straight to the shop once you see white smoke. Yours went away, though, so that's what's puzzling. I had a similar problem, and mine was bad DPF, so I deleted it and have had no problems since then.
Do you have a tuner/monitor that can run diagnostics? If not, I'd take it in and have it checked. Plenty of things can cause white smoke from the regeneration process, bad DPF (rather benign), to cracked EGR, head gaskets, etc. How's your coolant level in the degas bottle?
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #7 ·
All fluid levels are good I cleared the code and it's been running good. No issues at all.. It's got me puzzled as well.... Oh well, gives me a reason to tune and delete it!
 

·
Registered
Joined
·
270 Posts
All fluid levels are good I cleared the code and it's been running good. No issues at all.. It's got me puzzled as well.... Oh well, gives me a reason to tune and delete it!
Yep. Give that truck a reason to smile... Just be careful 1) where you live re: inspections, and 2) make sure you read plenty on what tuner/tunes to use. Everyone has their likes and opinions, just make sure you research them fully and have a decision point as to what you are choosing and why. You will be happier in the long run. Good luck.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #9 ·
Thanks for all the help man. Really appreciate it. And I think I'm going to go with a spartan tuner.
 
1 - 9 of 9 Posts
Top