Ford Power Stroke Nation banner

1 - 16 of 16 Posts

·
Registered
Joined
·
296 Posts
Discussion Starter #1
when i bought my truck the cel was on never thought anything about it until i installed my gauges im building max of 5lbs of boost. it laggy off the line but runs ok could this be the map sensor or throwing a over boost code?:confused:
 

·
Demon Dually
Joined
·
5,140 Posts
You need to run it for codes on a quality scan tool and see why the engine light is on. It should give you the reason why the light is on and will bring you much closer to the answer you are looking for.
 

·
Registered
Joined
·
296 Posts
Discussion Starter #3
LOLwell i had the local auto zone to check it but they couldnt get any thing so would i have to go to the stealership? or my local dealer getcha hyde {gillie hyde}LOL
 

·
Demon Dually
Joined
·
5,140 Posts
No there are a few guys from your home town on here. Ask if one of them will help you out. I am sure someone will help. It may cost you a case of adult beverages but that is way cheaper than the stealership.
 

·
Registered
Joined
·
296 Posts
Discussion Starter #5
well whats there names havent ran across any of them? jw but can you search for people in your area some how?
 

·
Demon Dually
Joined
·
5,140 Posts
At the top of each thread there is a members list tab that you can click and look through. Try doing a bit of searching. I don't make it a habit of memorizing everyones names and locations. It isn't my job to do so. I am trying to help you but you seem to have a little arrogance which won't get you far on here. I hope that your past post here just came across the wrong way by accident.
 

·
Registered
Joined
·
296 Posts
Discussion Starter #8
well i drove around with my map sensor unplugged and cant tell a big difference so im not real sure were to go from here? any thoughts?
 

·
Haters Gonna Hate
Joined
·
5,869 Posts
get it on a scan tool...... have u searched for members in your area maybe? im sure any one of the guys u got ahold of would be more than happy to help you out....
 

·
Demon Dually
Joined
·
5,140 Posts

·
Demon Dually
Joined
·
5,140 Posts
Oh there are three of you guys in Glasgow by the way.
 

·
DAMN THATS HOT!
Joined
·
1,001 Posts
You need to run it for codes on a quality scan tool and see why the engine light is on. It should give you the reason why the light is on and will bring you much closer to the answer you are looking for.
What is a quality scanner? I have a CEL on my truck and it will not start and when I attempted to scan it with a Edge Evo. it wouldnt feed me any codes and kept telling me to turn the key on even though it was on. It read codes fine on my dads truck though.:poke:
 

·
Demon Dually
Joined
·
5,140 Posts
You need something like Auto Enginuity software on a laptop with the ford package or a snap-on, mac, otc, etc. The parts store scanners will not do the job.
 

·
DAMN THATS HOT!
Joined
·
1,001 Posts
Im guessing that those are not cheep. haha Sounds like something cool to have though!
 
1 - 16 of 16 Posts
Top