Ford Power Stroke Nation banner

1 - 12 of 12 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter #1
Truck has been running crazy and has shut off a few times so i check for codes and CPS code came up and the back pressure sensor. Replaced the CPS and truck cranked and ran,still havin the other problems to.So i check the back pressure sensor and the tube was stopped up and fixed that and cleared all codes and cranked the truck back up and then i cut it off to check for codes and it did not have any so i cranked it up to drive it and it cut off. Checked codes again and the CPS came back and it would run a minute and cut off,finally it would not even crank again,so i went and got another CPS cleared the codes and it will not crank at all now and not showing any codes. Maybe someone can shed some light on this because i am lost.
 

·
PSN Pretender
Joined
·
1,926 Posts
What was the code number?

You might check the CPS connector to make sure the pins are not pushed out the back of them.
 

·
Registered
Joined
·
144 Posts
Discussion Starter #3
The first time i got codes it was a 340 and a 344 ,so i replaced the CPS and i cleared the codes and it cranked up.I also got a 470 which was the BPS and i fixed it and when i cranked it back up it ran for a few min and cut off and kept doin that and finally cut off and has not cranked since.I checked codes again i got the 344 again,so i replaced the CPS again and it tried to crank but that was it but i checked for codes and i do not have any.I took the plug loose and cleaded it and checked the wires and they seem to be fine but it will not crank.
 

·
PSN Pretender
Joined
·
1,926 Posts
You need to verify the Brown/White (BR/WH) wire has 5v and the Light Blue (LB) wire is a good ground, if these are ok suspect another faulty CPS.
 

·
PSN Pretender
Joined
·
1,926 Posts
Check that there is battery voltage on the Green wire. If OK, reconnect the sensor, back probe the Green wire and monitor for a signal that toggles between battery voltage and 1 to 2 volts as the engine turns. If you are using a volt meter turn the engine by hand, do not crank with starter.

If not CPS is junk, or there is a faulty connection somewhere else.
 

·
Registered
Joined
·
144 Posts
Discussion Starter #11
After all day ive been checking everything,it cranked up and ran fine for a few minutes again and shut off again,tried to crank it again and it ran and shut off and now it will not crank again. WTF? This is gettn to be old,check for codes and the 344 again CPS. cleared it and still will not crank and it shows no codes. Let it sit and check again and it shows the code.Man im lost lol.
 
1 - 12 of 12 Posts
Top