Ford Power Stroke Nation banner

1 - 12 of 12 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
My dad bought a 95 F-350 with 123000 miles and I have already asked in another thread about the loping problem. Now it is bucking and Has shut off a couple of times while driving does this sound like the CPS or could it be something else?

My dad lives 90 miles from Me in Mobile and just left when this started and now he is on his way back.

I have a new CPS for a 97 will this work if its the problem

Thank Guys I know yall will help me out you always do a lot of good infor here. Just don't have time to search right now.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
So this could be associated with the loping on start up? Where is the best place to buy the fuel pump ( lift pump)?
 

·
Premium Member
Joined
·
15,561 Posts
it could be totally different or it could be related, chugging and dieing like if he pushes in the gas pedal it doesnt gain any speed?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
The bucking is happening with the cruise on or off at a steady speed. And shut off at slow speeds 20mph or less.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #7
Had my transmission guy check everything yesterday and he thought it was a fuel delivery problem as well that is why I changed the filter and cleaned the screen and it was nasty. I also put the BB in the reg. All day to day this thing was running great except for the loping at start up. We even tried to get it to buck by driving it pretty hard with no luck.

My dad leaves for home and gets about 10 miles down the road and he is having to hold on for 8 seconds it bucking so bad and then at a stop light it shuts off and when he turns around headed back to my house is shuts off again and it bucked several times coming this way..

One thing I noticed is that the tach didn't move any while it would buck with me. ??????

He left it here and rode home with my mom sure glad I am not him, she didn't want him to buy it anyway.
 

·
Demon Dually
Joined
·
5,140 Posts
You need to put a fuel gauge on the schrader valve on the regulator and see what you are getting for fuel pressure for starters. That will either confirm or deny fuel related issues. Is the engine light coming on while it is doing this? Does the truck try to drive through the brakes when stopping and then stall? A little more info is needed to figure this out.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #9
You need to put a fuel gauge on the schrader valve on the regulator and see what you are getting for fuel pressure for starters. That will either confirm or deny fuel related issues. Is the engine light coming on while it is doing this? Does the truck try to drive through the brakes when stopping and then stall? A little more info is needed to figure this out.
I will try to check the pressure tommorow on start up. the engine light doesn't come on and it does not try to drive through the brakes it will just shut off once you have let off the throttle and coasting down.
 

·
Demon Dually
Joined
·
5,140 Posts
OK. With that info I would say to start with replacing the CPS. That sounds like it is most likely your problem.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #11
Well I replaced the CPS the old on was not in there tight and the wires where loosely installed, Since I have changed it I have drove about 30 and no bucking or shutting off lets hope this was the problem.

Thanks for all the help
 

·
Demon Dually
Joined
·
5,140 Posts
TADA!!!! Glad you got it fixed,
 
1 - 12 of 12 Posts
Top