Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
When I cold start my truck on my inclined driveway with the Parking brake on I sometimes have to get my RPM's up to 1700 going in reverse then the truck will make this loud bang sound like the brakes let go. Is this a caliper sticking issue or is there something wrong with the parking brake?
 

·
Registered
Joined
·
1,112 Posts
Mine did this in January. It's the parking brake. I took it to a shop. It ended up setting me back about $250. Off the top of my head, the guy said that everything had corroded together.
 

·
Demon Dually
Joined
·
5,140 Posts
Very common problem with our parking brake system is the parking brake cables get corroded and don't like to release. They are about 25 bucks a side and take just a few minutes to replace. It isn't even worth the time to mess with them. I messed with mine for over an hour trying to free them up and I can tell you that it is futile. I even bought a tool specifically designed for lubricating sheathed cable like this and it truly didn't make it any easier. I would just replace the cables and happy driving.
 

·
OEM Moderator
Joined
·
9,381 Posts
I agree on parking brake cables.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks for all the imput guys, I guess theres no way of getting around this except to replace them my brakes are pretty shot too so this would be a good excuse to do them to. Will it hurt the transmission any reving it up that high in gear and not going anywhere though?
 
1 - 5 of 5 Posts
Top