Ford Power Stroke Nation banner

1 - 12 of 12 Posts

·
BROKE as a JOKE
Joined
·
202 Posts
Discussion Starter #1
My brake light is on, but only sometimes. Most of the time, it fades on and off.

The resivoir is full, i have good brakes and pedal feel, and the e-brake holds well. Any ideas?
 

·
BROKE as a JOKE
Joined
·
202 Posts
Discussion Starter #2
Nobody?

proportioning valve? master cylinder? bad ground?
 

·
Registered
Joined
·
5,896 Posts
Vacuum pump starting to go out.
 

·
Registered
Joined
·
238 Posts
I've had the same deal for 2 years. It was doing this before Vac pump died, and still does it to this day, after reploacing it. Good luck, I hope you can find it.
 

·
BROKE as a JOKE
Joined
·
202 Posts
Discussion Starter #5
thanks. as long as i have brakes, i guess i dont give a ####.

stupid thing wasnt on today when i drove home, but it was on this morning after a chilly evening.

i bet its some corrosion in the wiring or sending unit that acts up depending on the weather/time/mood/tidal patterns.


...................i hate electrical gremlins
 

·
Registered
Joined
·
1,557 Posts
trust me, when/if that vacuum pump lets loose (if that is it), you'll wish you'd replaced it sooner. Luckily mine crapped out in the driveway, you just need a puller to get the pulley off. When that thing let loose I couldn't stop it, lol and it was just rolling down the driveway

do you hear any weird chirping noise from that area of the pump?
 

·
BROKE as a JOKE
Joined
·
202 Posts
Discussion Starter #7
trust me, when/if that vacuum pump lets loose (if that is it), you'll wish you'd replaced it sooner. Luckily mine crapped out in the driveway, you just need a puller to get the pulley off. When that thing let loose I couldn't stop it, lol and it was just rolling down the driveway

do you hear any weird chirping noise from that area of the pump?
no weird noises. runs like every other 7.3 ive heard. dad's fleet of 94-97 7.3's all had to have the proportioning valve replaced...i'm going to bleed them when i do the rear shackle mounts and see if it helps

lol ive never seen it happen, i would have been laughing my ass off
 

·
Registered
Joined
·
2,438 Posts
check your vac with a gauge you may have a bad or going bad hose ot the white hard line on the heater box. see if when it dose it if you chage the heater contriolls if you hear a hissing or see the vac gauge droppin goff
 

·
BROKE as a JOKE
Joined
·
202 Posts
Discussion Starter #10
Where is that? Down on the frame rail?
Either on the firewall below the master or on the frame below the master.

Check for the line from the master down to a little valve that then splits the fluid off to the 4 wheels.
 

·
Registered
Joined
·
433 Posts
my light come on when e-brake pedal vibrates down, i just push it up and the light goes out.
 
1 - 12 of 12 Posts
Top