Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
611 Posts
Discussion Starter #1
Today i shut the truck off after a 75mph high run and went to restart it less than 5 min later and it wouldnt start like it wont firing. I noticed my oil pressure guage bouncing between 0 and half (sorry dont have exact #s factory guage) finally when it did start it sounded real weak like the injectors werent firing good. Then it cought it self and ran with a slight miss and after sitting for two hours it fired right up without hesitation the oil pressure guage took no time tocome up when cranking and ran good for 25min and I shut it down again for 30 min or so and started fine and ran good afterwards....the truck has a slight miss every now and then and i dont have access to a good scanner to read icp,irp percentages. Im thinking a dieing hpop, and or a leak somewhere. How can i pressurise the system and check for leaks. Or does anyone in the richmond area have a nice scanner we could hook it too?
Thank you
 

·
Registered
Joined
·
611 Posts
Discussion Starter #2
Anyone?
 

·
Registered
Joined
·
1,830 Posts
Sounds like the oil is getting aerated.
 

·
Registered
Joined
·
611 Posts
Discussion Starter #4
could it just be the nature of the oil or could the hpop be the problem?
 

·
Captain Negativity!
Joined
·
3,109 Posts
The gauge turns on when it sees 5-7psi. Only way to tell where the problem is coming from would be to check the low pressure gearset. Make sure they aren't scored. Then look at the high pressure side regulator duty cycle. If it's at 85% trying to build pressure and the low side pump is good. Start blocking off cylinder heads to isolate the leak.
 

·
Registered
Joined
·
611 Posts
Discussion Starter #6
whats the easy way to block off the cyl heads to pressure check them?
 
1 - 6 of 6 Posts
Top