Ford Power Stroke Nation banner

1 - 3 of 3 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
I got a 95 f250 with an E4OD tranny that when I change from Park to reverse or drive, It seems to bog down for a second and idle back up to normal. It does this when ever it is shifted to any sort of drive gear either from neutral or park. I just got new injectors installed (baby Swamps) a month ago it started doing this since they were put in. I have a ts6 chip with swamps tunes on it. What would cause this to start happening. The motor has around 233k on it and all stock besides an cold air intake, cat delete, and new injectors with chip. I also had the tranny rebuilt about 8k ago. It ran great and shifted great before I had new injectors installed. Ive heard that these injectors make the tranny shift hard, but haven't noticed any of this so far. The truck has 4:10 gearing. The motor has been babied all its life and the mechanics that installed the injectors said it was one of the most powerful and best trucks they have seen with 233k. When it shifts, it idles down like it wants to almost die, but it doesn't.
Also when driving down my driveway, every now and then it will die. Im in the sticks and my driveway is half a mile long on a very step hill that has a sharp switchback. I usually just idle down it in first and then midway around a switchback, I shift it to 2nd and it just dies cuz the motor bogs down. Its happened twice there now over a month and once on a freeway off ramp. Just that time I took the motor out of over drive. Got to the bottom about a quarter mile later and noticed it had died. What would cause this to happen?
 

·
Former Ford Trans Engr.
Joined
·
3,088 Posts
Low trans fluid can do this.
 
1 - 3 of 3 Posts
Top