Ford Power Stroke Nation banner
1 - 16 of 16 Posts

·
Registered
Joined
·
166 Posts
Discussion Starter · #1 ·
My hpop is showing 5.7 psi at crank. I believe it's suppose to bee at 500. Anyone know? Should I change the stc fitting out or go ahead and change the whole pump? Or could I change the ipr. Out? It's only showing code for low icp and I've changed the icp... any suggestions?
 

·
JGman141
Joined
·
859 Posts
Try to unplug the icp sensor and see what it does. If it's still the same problem id switch out your ipr
 

·
Registered
Joined
·
50 Posts
My hpop is showing 5.7 psi at crank. I believe it's suppose to bee at 500. Anyone know? Should I change the stc fitting out or go ahead and change the whole pump? Or could I change the ipr. Out? It's only showing code for low icp and I've changed the icp... any suggestions?
If you have a 2004 like your sig says, you don't have the stc fitting. That was only 2005-07 MY.
 

·
Registered
Joined
·
166 Posts
Discussion Starter · #5 ·
from what ive read since this post none of the 04 have the stc fitting whether that is correct or not i dont know.. I took icp out and cranked and still not start.. Im going to pull my ipr and see what the screen looks like on it this week when i am off.. Thanks for the help.
 

·
JGman141
Joined
·
859 Posts
from what ive read since this post none of the 04 have the stc fitting whether that is correct or not i dont know.. I took icp out and cranked and still not start.. Im going to pull my ipr and see what the screen looks like on it this week when i am off.. Thanks for the help.
You don't want to fully pull it out, you just want to unplug it and them try to crank to see of it will go.
 

·
whistle tits
Joined
·
3,498 Posts
Is your dash oil pressure gauge coming up while cranking? If not, pull the oil filter, and press down on the small black spring loaded drain in the bottom of the filter housing. If the housing fills up decently quick, your lpop is probably okay, but if it won't fill, your lpop may need to be replaced, and hopefully you don't find needle bearings in it.
 

·
Registered
Joined
·
166 Posts
Discussion Starter · #8 ·
Oil pressure gauge does not move when I crank it. I will try that with the filter when I'm off work this weekend. Thank you for the tip!
 

·
Registered
Joined
·
166 Posts
Discussion Starter · #9 ·
Jgman, I said that wrong I unplugged the icp and cranked and still the same....
 

·
Jackleg Mechanic
Joined
·
881 Posts
What are you reading hpo pressure with. Its been a while since I used my Banks monitor but iirc it reads x 100, ie 5.7= 570
 

·
Registered
Joined
·
50 Posts
Is your dash oil pressure gauge coming up while cranking? If not, pull the oil filter, and press down on the small black spring loaded drain in the bottom of the filter housing. If the housing fills up decently quick, your lpop is probably okay, but if it won't fill, your lpop may need to be replaced, and hopefully you don't find needle bearings in it.
When my stc fitting took a dump, my pressure gauge on the dash would not move no matter how long I cranked it. So I am not certain that is a for sure indicator of a low pressure oil issue. The gauge will register pressure after the engine fires on my truck.

Also note that the gauge, is not really a gauge, and is more just a dummy light that shows a minimum pressure is met. Instead of a light they made it an analog style gauge, which is "cooler"...or something.
 

·
Registered
Joined
·
166 Posts
Discussion Starter · #15 ·
is it possible to check to verify if my ipr sensor is bad or not?
 

·
Registered
Joined
·
166 Posts
Discussion Starter · #16 ·
So i did all the test to find out i have bad hpop.. ive got an adrenaline pump and putting her in cant wait...
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top