Ford Power Stroke Nation banner

1 - 15 of 15 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter #1
went to install itp overboost annihalitor and took the old hose off the map sensor and part of the map sensor came with it so i glued it back on and of course it doesnt hold just broke off like nothing also my tube seems to short going from the turbo to the map sensor mounting location does the early 99 need to be longer. i havent ran it yet so will it run normal without it being hoooked up or will it be all messed up since it doesnt think its got any air. thanks and is powerstrokeshop the cheapest place to get it
 

·
Registered
Joined
·
1,134 Posts

·
you want some of this?
Joined
·
2,922 Posts
It'll cut back on the power if its unhooked. Minegot disonnected when doing some stuff, and it still started and ran fine. But when I hookked it back up it was a lot stronger. If the map doesnt see boost, it doesnt add the fuel like its supposed to. On the upside, there was no smoke at all from the tailpipe.:doh:
 

·
Registered
Joined
·
128 Posts
Discussion Starter #7
yea i took it for a spin and could only get 20psi and not hte power it normally has

dang i already ordered one from powerstrokeshop but thanks alot i appreciate it, and thanks for all the help
 

·
Sleep well my brothers
Joined
·
2,063 Posts
My hose was too short as well. I used part of my stock hose from the Y to the MAP & part of the ITP O/B hose connected it together with a T for my boost gauge and it has been working with no problems.
 

·
Sleep well my brothers
Joined
·
2,063 Posts
Oh and try not to run the truck too much with it not connected. My buddy drove his for like a week not knowing it had popped off and he had to replace a few things because of it not being connected. I don't remember what the dealer had to replace but he told me they replaced a couple of things. And he's finally a member here so maybe he will read this and chime in,but I wouldn't hold my breath waiting on him.
 

·
Village Idiot
Joined
·
8,209 Posts
sooo in hind site would you do it again like that , just being a lil more careful

or just cut the hose and put a tee in.
 

·
Registered
Joined
·
128 Posts
Discussion Starter #11
thanks guys ill try not to drive it if i dont have to the sensor should be here monday and maybe ill splice the old hose wth the new one kinda thought it should be long enough from the start though are the early 99 turbos in a slightly different postion for the outlet i know the turbo itself is different but the directions say about cutting some of the hose off and i dont have enough
 

·
Registered
Joined
·
1,612 Posts
I always just take a steak knife and slowly/gently slice down the length of hose when I am taking off hose like that simply because it never fails, I always break something when I try to pull it off, lol
 

·
All done now
Joined
·
22,486 Posts
I carry razor knifes for stuff like that, not mixing my kitchen tools and truck tools up.
 

·
What else?
Joined
·
4,156 Posts
Giving it a nice, easy twist before you try pulling it off will usually break it loose. Makes it like 10x easier then. ;)

Dave
 
1 - 15 of 15 Posts
Top