Ford Power Stroke Nation banner
1 - 4 of 4 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
and it went great! So I was having cold start issues that cleared up when oil was warm. Tried Rev-X and it worked the first time but later my issues came back. Tried it again and did not work as good. I had my truck scanned with the Ford scanner and it came back with bad injector in #2 and #3. Figures they would be on both banks. So I decided to do one at a time for financial reasons so I started with 3. Prior to this I had never worked on a PSD before. Install went great minus the crappy oil rail bolts which required me to make my own small tool to fit in there. Truck runs a TON better and I will go after #2 soon.

So when I got in there I found something interesting. # 3 had a red top and was clearly an aftermarket injector...figures. Anybody know who makes injectors with a red clip on the top? All others looked stock. I will try and post pictures soon. I am very curious to see if #2 is aftermarket as well, as this would prove that aftermarket replacements suck (not including performance ones).

I just wanted to say thanks for all those that post on this forum and give us new guys lots of great info to educate and use for installs. There is also a great video on YOUTUBE by a senior tech that shows an entire injector install. It was very helpful. I also went ahead and did dummy plug and standpipe (easy install). Will do this on the other side as well.

:ford:
 

·
Administrator
Joined
·
33,267 Posts
I couldn't find any red tops doing a google image search

I don't think aftermarket replacments suck most are rebuilds as are the ones you get from Ford but I would only use ones from a reputable source like Alliant ETC

or do you think yours are not even Ford bodies??

can u post the u tube link you used
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top