Ford Power Stroke Nation banner

1 - 14 of 14 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
I had antifreeze dripping off the back of my engine by the oil filter. I took it in for service and the dealer replaced the water pump, pressure tested and gave me my truck back. I started to smell antifreeze again in about 3 days and noticed it was wet by the oil filter again. I power washed the bottom of the engine and removed all the old residue. Now the antifreeze is back by the oil filter again. It is a small leak but needs to be fixed. Has anyone had a water pump replaced yet? I also was curious where it was located to be dripping from the back?
 

·
Registered
Joined
·
2 Posts
There are two cooling systems on this engine. The primary pump is in front on the drivers side. The EGR cooling system is in the area you are describing. I have attached pictures of both:
 

Attachments

·
Registered
Joined
·
1,888 Posts
Yep, I was going to say, there's two systems on these. I also was going to ask if there is an oil cooler on these like on the 7.3L? If so, I'd suggest looking there.
 

·
Registered
Joined
·
284 Posts
We have had several JW pumps replaced, but they all leaked off the front side of the engine... Interesting... keep us posted on what you find..
 

·
Registered
Joined
·
2 Posts
Yep, I was going to say, there's two systems on these. I also was going to ask if there is an oil cooler on these like on the 7.3L? If so, I'd suggest looking there.
That's a good question. The oil cooler is on the rear driver side of the engine. Here is a picture of that:
 

Attachments

·
Registered
Joined
·
1,888 Posts
ahh, it's a much different design than the 7.3L's not that I'm surprised by that. Thanks!
 

·
Registered
Joined
·
64 Posts
Discussion Starter #7
I just looked at my service receipt. The part number for the water pump replaced is bc3z 8501. The leak to me would seam to be on top of the intake on the passenger side and drips down the back of the engine by the oil filter. It goes back in Tuesday to let them work on it again. They also used 2 gallons of antifreeze.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #8
Update: just picked the truck up from the dealer yesterday. They said they could not find a leak under a pressure test. Funny, there is antifreeze by the oil filter this morning LOL. So i guess screw it till it pours out.
On a brighter note, since it was in there I had them perform TSB 11-07-10. That is the latest update on the transmission. This update included changing out 3 shift solenoids in the trans and updating the software. This update made me feel like I have a brand new truck. I cannot believe how much better it shifts. I wish I would have done this a long time ago.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #9
Update again: Truck now has a puddle of antifreeze dripping off the block by the starter and oil filter every morning. The drips starts at night when the system is not under pressure. Where is the heater core in these trucks? I am thinking a line might be loose back there. the service guys better find it this time. This will be the third try.
 

·
Registered
Joined
·
28 Posts
I was smelling coolant but couldn't find any dripping on 2011 with 32k miles. Took in for service and the radiator was replaced. I've been driving for a couple weeks now and seems like I'm still smelling coolant. Making a mark on the resevoir to monitor its level. I'm hoping its my overly cautious senses and not another leak.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #11
I was smelling coolant but couldn't find any dripping on 2011 with 32k miles. Took in for service and the radiator was replaced. I've been driving for a couple weeks now and seems like I'm still smelling coolant. Making a mark on the resevoir to monitor its level. I'm hoping its my overly cautious senses and not another leak.[/QUOTE

A buddy of mine had his radiator replaced on his 2011. The dealer always pressure test mine. They replaced the water pump and I still smell coolant. With it dripping off the back of the engine, I think it has to be a line loose somewhere. They need to pull all the junk off the top of the engine so they can see what is going on. I have been all over it with a flash light and have not found it yet. Here is a couple of pics, looks like this every morning.



 

·
Registered
Joined
·
64 Posts
Discussion Starter #12
So far the dealer has had the truck 2 weeks. They finally found a drain plug on the right side of the block leaking. They have 2 more in for service doing the same thing. The tech removed the small plug with his hand. I guess these did not get tightened up from the factory. I went to pick it up and the water pump that was replaced a month ago was leaking again, so it is still in the shop.
I started looking for a new truck today. I dont believe this one is going to make it with the water leak issues. Good luck guys.
 

·
Registered
Joined
·
1 Posts
Mine is doing the same thing. Loosing about a quart of coolant each week only when truck is sitting. Have searched everywhere at back of engine and cannot locate leak. Good to know to look at drain plugs.
 

·
Registered
Joined
·
620 Posts
I have also seen the heater core inlet tube o ring leak and fill up the valley, only once though. With the radiators i have noticed that you can see orange residue on the cooler fins if you shine a light on them and look down, thats if they are leaking.
 
1 - 14 of 14 Posts
Top