Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Delaware OBS
Joined
·
11 Posts
Discussion Starter #1
I have an 01 with 70,000ish miles and a 7.3L. When I purchased it was stock with aluminum wheels and 265/75/16 E-rated tires. It would "wander" going down the road. I NOW have a Procomp 4" lift and 315/75/16 BFG's d-rated on factory wheels. I thought that new springs, shocks, new ball joints, u-joints, and steering stabilizer would cure this.....it has not. I do not have a rear sway bar. Any suggestions. Thanks in advance

PS: I saw someone make "special" bilsteins.....but are they available for lifted X's?
 

·
Registered
Joined
·
103 Posts
PM OBSWIZ he does the custom valved Bilsteins and will be able to answer that question.
 

·
Registered
Joined
·
4,810 Posts
We have helped hundreds of Excursion owners transform the handling of the EX. Pm me if I can help.

Cary
 

·
Registered
Joined
·
4,865 Posts
From what I have found lately with a lift almost assuredly you need a full alignment. Almost certainly the stock springs were an issue but you still have changed the various specs on the alignment. There is some very goo info out there on getting these things to track sell after you have handled getting the inferior parts such as the leaf springs etc taken care of. Cary likely has the most experience of anyone with setting up the suspension on these vehicles.. Add in a good alignment with the proper specs and possibly steering gear lash adj unless the box is shot and a fluid flush you can get these things handling very well especially for a leaf sprung front end.
 
1 - 4 of 4 Posts
Top